Host is a Dell 2850 with 16 GB RAM running CentOS 5.x and VMWare Server 1.0.8, 300GB SCSI disks hosting 6 VMs (mixed Windows 2003 Server/CentOS 5.x guests.)

I'm wanting to change the Host memory configuration (Host/Settings/Memory) to fit all VM memory into reserved host RAM. This is one of the three options on this dialog. However, selecting that option and clicking OK returns an error:

You do not have permissions to perform this operation.

Permissions to /etc/vmware/* are 664 for files, owned by vmuser.vmuser.

I can add new VMs and they are appropriately added to vm-list (which is generated by the VMWare console), so I clearly have permission to write to files in /etc/vmware.

The only topics I've seen that discuss this issue talk about permissions, however, that is clearly not the problem in my instance.

Does anyone have experience with this?

  • 2
    Vmware Server 1.0.8 is well beyond the End of Life. You should seriously be looking at the alternatives.
    – Zoredache
    Mar 14, 2012 at 21:42
  • we are, but for a variety of reasons, that that can happen yet.
    – bo gusman
    Mar 14, 2012 at 21:50

1 Answer 1


It may not refer to filesystem permissions. In general, VMware products (like Workstation) do not let you change memory allocation settings unless you are running as root.

The system account you use might matter, depending on your authorization scheme. Try logging into the web interface as root and changing the setting.

In line with Zoredache's comment, you definitely need to convert off those VMs and move to a more appropriate (and supported) virtualization platform. It was surprisingly painless to move from Server 2 on Ubuntu 8.04 to ESXi 4.1 U1.

  • I had never considered using the console as root. Shazaam! And once again, we are looking at alternatives, particularly RHEV. But it simply won't happen overnight.
    – bo gusman
    Mar 14, 2012 at 23:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .