I'm not a systems engineer, but I can do the basics. I've inherited a Lotus Notes setup in my new job. I've no experience with Lotus Notes/Domino, however.

Everything was working fine.

Today the router died and I replaced it (with a D-Link DSL-2740B). Setup seemed to go okay, and Lotus Notes works fine for computers within the LAN. It also works fine for sending emails to external addresses.

It doesn't work outside the LAN: people cannot connect to the server, and we're not getting any emails that are sent from outside addresses.

Webmail (previously at mail.mycompany.com) doesn't work any more (it fails with a "The connection to the server was reset while the page was loading." error).

I strongly suspect that this is a port forwarding or firewall issue. I've tried forwarding ports 80, 1352, and 25 through to the correct server. A port scan shows that ports 25 and 1352 are fine, but that port 80 failed with a "No connection could be made because the target machine actively refused it" error.

So I'm stumped. I don't know how the old router was setup to allow the webmail or notes traffic in. At this moment in time I'm more concerned about getting webmail up and running because that, at least, will allow people to start collecting emails.

Please do point me in the right direction for further diagnosis, reading, or whatever I need to do to get this fixed. Thanks!

  • 1
    Did you check what ports are open on the server you're pointing the port forwarding to, to verify that's what it was serving from? And what the logs said, and what ports your internal machines are connecting to? – Bart Silverstrim Mar 15 '12 at 13:51
  • Check the server settings to see if the HTTP port (80) has been changed to something else (such as 8080). Can you access the server on port 80 on the internal LAN? – Per Henrik Lausten Mar 15 '12 at 13:52
  • 2
    The old router apparently had port settings that is now not available on the new router – Per Henrik Lausten Mar 15 '12 at 13:54
  • I'm unsure what you mean here. Can you elaborate? What kind of settings? – Lee Mar 15 '12 at 14:06
  • Typing in the server's external IP address directly (from inside the LAN) takes me to the router login page. Does this give any more clues as to where I've messed up? – Lee Mar 15 '12 at 14:13

There are a few checks here and few things to note.

  1. Please change your router - I have looked at the router manual and it doesn't allow port 80 to be changed from the router config. This means that you won't be able to host the website on port 80 anymore. I would recommend a proper router like Cisco or Draytek if the budget allow for it, if not at least Netgear - most Netgear router will allow you to change router port.
  2. Check whether you have static IP or dynamic IP. If dynamic, is dynamic dns service being used at all?
  3. Check SMTP port on the server: http://www-12.lotus.com/ldd/doc/domino_notes/6.5.1/help65_admin.nsf/b3266a3c17f9bb7085256b870069c0a9/9e2e02ebb636acc885256dff004b1f2a?OpenDocument and enable it on the firewall
  4. From your command prompt ping mail.mycompany.com and check which IP address is being displayed to confirm whether mail is hosted inhouse or externally or if it goes through a spam filter service. Also do the same for the website and see what the ping reveals.

Hope this helps you in resolving the issue.


Disable the configuration Page from the WAN side.

If that doesn't work, see if you can open the webmail via the LAN-ip. it is possible the webmail was on port 8080 and the NAT converted it to 80.

ExternalIP:80 --> RouterWAN:80 - NAT --> Server:8080 
  • Thanks for your response."Disable the configuration Page from the WAN side." - I'm not sure I follow. The router config page? It's only set to appear for 1 specific internal IP. I've tried 80 -> 8080, 8080 -> 80, neither appear to work. Can't get it to appear via LAN-ip. – Lee Mar 15 '12 at 14:27
  • So, open up the mail server and see on which port it is serving the Webmail. – Bart De Vos Mar 15 '12 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.