Mac OS X Snow Leopard
Windows Server 2003

Windows Folder "Videos"
Share Permissions on Videos
- Everyone
NTFS Permissions on Videos
- System (Full Control)
- Domain Users (Modify)
- Domain Admins (Full Control)

Mac user Michael is a part of the Domain Users group. He connects to Videos using cifs://server/Videos and authenticates with his username Michael. Michael copies over a file "dance dance baby.avi".

User Jon opens the Videos folder but cannot see the dance dance baby.avi file.

Checking the dance dance baby.avi file permissions here is what I see:

Everyone - Read, Write
Domain Admins - Full Control
Michael - Read, Write
Owner of File - Michael

So here's my question, how come when Michael copies a file over from a Mac, the permissions on the file get changed even though Michael has no rights to change permissions?

If the same file is copied over from a Windows machine, it just inherits the proper permissions from the parent Video folder.

Am I missing something? Are my permissions wrong? Thanks.


  • Whenever a file is created, the process creating it can set whatever permissions it likes. Also, the owner of a file - the account that created it - can always change the permissions. You can mitigate the second issue by setting "modify" instead of "full" permission on the share. Mar 16, 2012 at 4:26
  • Actually, if you remove the CREATOR OWNER permissions they won't be able to take ownership of the file. Yes I have the perms set as modify instead of full. The problem has been solved, it's because I was using cifs not smb.
    – Michael
    Mar 16, 2012 at 15:51
  • just to confirm, the share permissions are set as "Everyone: Modify"? The question doesn't say. Mar 17, 2012 at 23:23
  • 1
    CREATOR OWNER permissions don't have anything to do with being able to take ownership. When a file is created, the person who created it is the owner and (unless blocked by share permissions) will be able to change the permissions on it. Mar 17, 2012 at 23:26
  • However, if I understand your problem rightly, none of this matters; you don't actually want to stop users from deliberately changing permissions, you just want the default permissions set the way you want them. Mar 17, 2012 at 23:27

1 Answer 1


Looks like using smb:// instead of cifs:// to connect fixed the issue.


Although its main purpose is file sharing, additional Microsoft SMB Protocol functionality includes the following: - File, directory, and share access authentication

  • This issue is occurring (again?) even when using SMB://.. Here is a similar thread. The issue is marked as resolved, but it definitely is NOT. experts-exchange.com/questions/28430958/… I had to remove Write permissions from the .TemporaryItems folder.
    – goofology
    Jan 15, 2016 at 22:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .