I can't get the password from the AWS console tools. I can reach the box via rdesktop.Can I reset the password remotely? If so, how to go about doing this? the machine is Windows server 2008 R2 Datacenter.

  • Why can't you get the password from the AWS Console? Do you not have the key? Does the key you have not work or does it say there's no password generated for this instance?
    – bwight
    Commented Mar 15, 2012 at 23:17
  • It says password is not ready... after 10 hours. The key is ok because I have since logged into linux boxes using it.
    – marabutt
    Commented Mar 15, 2012 at 23:20
  • 2
    why don't you just terminate instance and launch new one? Commented Mar 15, 2012 at 23:34
  • I have tried this several times. I need this specific instance.
    – marabutt
    Commented Mar 15, 2012 at 23:38

2 Answers 2


I ran across this scenario and found a solution using the unique setup of EC2 on another site: http://www.smattie.com/2012/01/23/video-remotely-reset-windows-password-via-ec2-config-service/

The video is long, so to summarize the steps:

  1. Create a new scratch EC2 instance running 2003 server, and log into it.
  2. Shut down your lost instance (the one you can't log into) from the AWS console.
  3. On the EC2 console, go to Elastic Block Store/Volumes and find your C: disk volume, and Detach it.
  4. On that same volume, attach it to your scratch EC2 instance. You can see it appear in Disk Manager and you'll get a new D: drive letter.
  5. Go to D:\Program Files\Amazon\Ec2ConfigService\Settings\ and edit config.xml with notepad
  6. The first setting in the file is for the Ec2SetPassword plugin; change the State field from Disabled to Enabled. Save & close.
  7. On the AWS console, Detach the volume from the scratch instance (don't worry, it safely detaches from Windows)
  8. Attach the volume to your original lost instance, as /dev/sda1
  9. Start the instance. After a few minutes, run the Get Windows Password function which will have the newly generated password.
  • 1
    This solution worked for me, but with Windows 2k8/2k12, you may need some additional steps to make the reattached drive boot. Information can be found on the aws forums or at this blog post.
    – JoshRivers
    Commented Feb 5, 2013 at 1:28
  • 2
    Also, do remember to use "/dev/sda1"...just "sda1" doesn't do the trick (even if that's what you see in the console UI)
    – JoshRivers
    Commented Feb 5, 2013 at 1:28
  • I'm running into a signature collision issue after I attach the volume. Any workarounds for that?
    – hunter
    Commented Oct 20, 2013 at 13:59

When the password says not ready for an extended period of time. It usually means that this server was launched from an AMI. The keys don't work for AMI's The keys don's work for AMI's that have modified the EC2Config service. When you save a windows AMI you need to make sure you have the administrator password written down or better yet memoried. Standard practice with amazon is to change the password the first time you log in.

If you need some type of data on the instance you can shut it down. Detach the harddrive and attach it to another instance to recover any data. But my suggestion is to use a new instance. There's nothing you can do at this point unless you have the original instance running that was used to create the AMI. The password for that machine would be the same as the machine that will not generate the password for you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .