I have a Windows 2008 R2 server with all the latest updates that acts as a Domain Controller, and it also has the Windows Deployment Services service on it. DHCP is handled by a separate router.

Whenever this server is rebooted, say after security patches, WDS does not come back up. The service is currently set to Automatic - Delayed Start, because at first I was hoping that maybe it was just trying to start up too soon. But that has not helped.

When I RDP to the server or connect to it via RSAT, I am able to start the WDS service by hand just fine. But I don't want to have to restart it manually every time the machine reboots.

Here are some of the related error messages I see from WDS when the machine reboots and WDS fails to come back up:

Machine reboots at 3AM after installing updates.

  • Information 3/14/2012 3:09:30 AM WDSServer 1025 WDSServer The RPC server started on TCP port 5040.
  • Information 3/14/2012 3:09:30 AM WDSServer 517 WDSServer Provider BINLSVC loaded from C:\Windows\system32\binlsvc.dll and initialized successfully.
  • Information 3/14/2012 3:09:32 AM ESENT 301 Logging/Recovery svchost (2652) DDP: The database engine has begun replaying logfile D:\RemoteInstall\Stores\Drivers\Metadata\DDP.log.
  • Error 3/14/2012 3:11:35 AM WDSServer 513 WDSServer An error occurred while trying to initialize provider WdsImgSrv from C:\Windows\system32\WdsImgSrv.dll. Windows Deployment Services server will be shutdown. Error Information: 0x54B
  • Error 3/14/2012 3:11:36 AM WDSServer 257 WDSServer An error occurred while trying to start the Windows Deployment Services server.
    Error Information: 0x54B

Those are pretty much the most relevant event log entries as far as I can tell.

edit: .... And I think I just answered my own question. I know that WDS depends on being able to contact Active Directory... and like an idiot, I had my two DCs for this domain configured to reboot for updates at the same time. I have corrected that so that the other DC will be up while the first is trying to reboot. Hopefully that fixes it.

  • If that does fix it, go ahead an add an answer here (and accept it as correct). Mar 17, 2012 at 0:11

2 Answers 2


Answered my own question, the problem was both DCs restarting at the same time.


Based on what I have seen Your comment about active directory accessibility is right on the mark. I ran into a similar problem in a test lab with WDS and MDT running on the only DC. I worked around it by setting the service to restart on failure. I also did some reading on defining service dependencies but nothing really came of it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.