For some reason I do not know, several default packages in my Fedora 12 installation have gone missing, removed or uninstalled. Now, reinstalling fedora 12 is not a good idea in my current situation. Can someone guide on how can I install yum package using rpm? I mean, I can't find the repository for yum.

Thank you very much!


An Hour Later, I have installed yum successfully but installing all the missing dependencies one by one! Thanks everyone!

  • While you run from the console yum install rpm name what error do you get. – neolix Mar 19 '12 at 7:22
  • i don't have yum installed. so i'l definitely get an error... I've managed to get a yum tar.gz file from its official website, but I run into another package dependency when I tried to run it. libpython2.4.so.1.0. So I guess, is there any way to install yum and its dependencies with just rpm, or sources? how can i do this? Thanks! – ultrajohn Mar 19 '12 at 7:31
  • so doing a which yum doesn't return anything? – qweet Mar 19 '12 at 7:36
  • now it returns something, after I tried to install yum from source a I got from its official page. But I run into dependencies issues i.e. python lib, when I tried running it. – ultrajohn Mar 19 '12 at 7:38
  • what is your "python" version & which is "yum" version ? – neolix Mar 19 '12 at 7:40

You might be in for a ride, especially if you're missing dependencies. Here is a page where you can view mirrors of the RPM and its dependencies, and search for the dependencies you don't have, in case the following doesn't work.

rpm -Uvh ftp://ftp.uni-bayreuth.de/pub/redhat.com/fedora/linux/releases/12/Everything/i386/os/Packages/yum-3.2.25-1.fc12.noarch.rpm
| improve this answer | |
  • aah, getting to the dependencies individually is a bad idea... – ultrajohn Mar 19 '12 at 7:59
  • Alternatively, ctrl+f the dep list against the baserepo (X64)/baserepo (i386) and install what's needed – qweet Mar 19 '12 at 8:19
  • that centralized list of x64 os packages would have helped me a lot.. – ultrajohn Mar 19 '12 at 9:08

As @qweet pointed this is not a trivial thing due to the large number of prerequisites for yum, most notably python packages. My strategy would be

1. get the yum rpm (do not use source code) from a F12 repository (releases/12/Everything/i386/os/Packages/) and place in a fresh folder
2. try to install yum: rpm -Uvh ./yum.xxx.xxx.rpm
3. If dependencies have been deleted also then you will get plenty of complains
4. Download also one by one the dependencies
5. try #2 above again
6. repeat 4,5 until you have no errors!!

Of course if you have a F12 disk things get even easier. Have fun

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.