0

I have a windows 2003 server using IIS6 and PHP. I am using a PHP Framework and on loading a page of the framework, after 15 seconds I get the following error:

FastCGI Error

The FastCGI Handler was unable to process the request.
Error Details:

The FastCGI process exited unexpectedly
Error Number: -2147467259 (0x80004005).
Error Description: Unspecified error
HTTP Error 500 - Server Error.
Internet Information Services (IIS)

My Fast CGI settings are as follows:

[PHP 5.3]
ExePath=c:\php5.3\php-cgi.exe
EnvironmentVars=PHPRC:C:\php5.3
IdleTimeout=9000000
ActivityTimeout=900000
RequestTimeout=900000
InstanceMaxRequests=10000

Does anybody know whats going wrong?

UPDATE

After looking at the Event Viewer, I can see the following error: Faulting application php-cgi.exe, version 5.3.9.0, faulting module php5.dll, version 5.3.9.0, fault address 0x00091818.

1 Answer 1

1

What exact version of PHP are you using?

You should use the VC9 versions, to use PHP with IIS.

Also you will need to have the Microsoft 2008 C++ Runtime installed:

x86 version: http://www.microsoft.com/downloads/details.aspx?FamilyID=9B2DA534-3E03-4391-8A4D-074B9F2BC1BF&displaylang=en

x64 version: http://www.microsoft.com/downloads/details.aspx?familyid=bd2a6171-e2d6-4230-b809-9a8d7548c1b6&displaylang=en

Also, if register_globals is set to 'On' in php.ini, you will get this error.

0x80004005 is normally a security issue.

3
  • Yes I have both VC9 php and the 2008 C++ runtime. The exact version of php is 5.3.9 but i've tried other 5.3 versions aswell
    – Matt
    Mar 21, 2012 at 12:04
  • Also register globals is set to 'Off'
    – Matt
    Mar 21, 2012 at 12:43
  • That is weird stuff then. Is there any information in the Windows error log?
    – JapyDooge
    Mar 21, 2012 at 17:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .