I have a server that can't connect to shares using FQHN or IP. I can ping other servers by IP and FQHN. I have rebooted the server and still no luck.

The error is:

System error 64 has occurred.

The specified network name is no longer available.

What could be causing this problem?


Event Logs are Your Friends

They're here to help you! Look in the System event log for network related errors. I would not be surprised if there were errors from Source: MrxSmb or Source: TCPIP

Network Monitor doesn't bite... too hard

Capture traffic from your network card and inspect the errors. In fact, set up Network Monitor on the troubled server as well as the endpoint you're trying to connect to. In Network Monitor, the TCP Retransmit option will show you retransmit statistics. In the Capture Statistics summary frame, I would wager a bet that you'll see some interesting traffic rejections or hardware errors.

For some more information, check out Microsoft KB325487.

What do the above two troubleshooting techniques prove?

You've got hardware issues. It could be any of the following

  • Bad drivers on the server
  • Bad BIOS in need of an update
  • Motherboard / chipset drivers need updating
  • the NIC and switch port are not negotiating nicely. Make sure that both are set for 10/100 full duplex or 1Gbit full duplex. Turn that auto-negotiate nonsense off. Whatever you do, make sure that both server NIC and switch port agree with each other (unless they both agree to negotiate - don't let them do that).

That is not an exhaustive list, but gives you a start.

SMB version 1 vs. version 2

Consider what OS your server is trying to connection to. Windows Server 2003 / XP and earlier use SMB 1, while Server 2008 / Vista and newer use SMB 2. To narrow the issue down, consider disabling one and then the other.

The registry hive to muck with SMB versions is HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters In that hive, add a new DWORD value with the name SMB2 and set the value to 0. That disables SMB 2. Then try to connect to shares and see what the result is.

If that "solves" the issue, then you may need to re-install some of the networking components of the OS.

Use the "Maximize throughput for file sharing" trick

As per the ServerFault Q/A titled "Intermittent connection to Windows 7 shared folder from Windows XP workstations" there's an old trick on Windows machines involving "How to Optimize Windows NT Server Using the Registry."

When you configure one of the four options for the Server service, the information is saved to the following two registry keys: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters\size Your choices for this registry key are 1,2 and 3. 1 = Minimize Memory Used 2 = Balance 3 = Maximize Throughput for File Sharing and Maximize Throughput for Network Applications HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

Your choices for this registry key are 0 and 1. 1 = Maximize Throughput for File Sharing 0 = Maximize Throughput for Network Applications

The above technique has been used in your situation to renew communication with SMB shares.

But above all...


Seriously. They're awesome.


I had the same issue and finally found the solution. I have a special set up so this might not apply to your case but this is what my issue was.

I was mapping network drives to shares on my QNAP nas. This NAS is also a iSCSI target for my ESX host. The nas has 2 NIC's and I dedicated 1 of the NIC's for the iSCSI traffic, with it's own IP.

For some reason, my DNS server had 2 entries for my nas with different IP's.

So obviously, when I tried to map the drive with the name, sometimes it would point to the wrong IP and SMB is not allowed via that IP (qnap service binding) so it wouldn't allow me. I removed the wrong DNS entry and the issue was solved.


The issue was with our Citrix NetScalers. There is now a workaround in place and a support ticket has been logged with Citrix.


We had this same exact problem.

The solution for us wound up being the following registry change on our Windows 2012 Server, then reboot:


change from the default value to this new value below:

Default Value: SamSS Srv2 New Value: SamSS Srv

Or, if you want to be lazy, just save this to a .reg file and open it on your server:

Win8dows Registry Editor Version 5.00


Don't forget to reboot after making this change!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.