I'm trying to run a program that requires glibc 2.7, but I'm running it on CentOS 5.5. Is there any way to do this? I can't upgrade to CentOS 6.
Hmm. glibc 2.5 is a dependency on pretty much everything in CentOS5. If you change it to glibc 2.7, your box will explode.
Here's some discussion over in the CentOS forums:
I ran into this issue a couple times, most recently while back using Snort. Attempting to upgrade to 2.7 will.definately blow up yourto box. I rendered my test system unbootable when I tried this previously. Your best bet is to upgrade if at all possible. Failing that many applications can be recompiled against glib 2.6. If you have to deal with a no install from source on your production infrastructure take a look at how to build RPMs. A lot of products either include a spec file or there is one publically available.
Did you have a problem with your keyboard when writing the first part? Mar 22, 2012 at 2:03
New mobile phone. Autocorrect needs some adjustment. Mar 22, 2012 at 2:13