6

I'm trying to run a program that requires glibc 2.7, but I'm running it on CentOS 5.5. Is there any way to do this? I can't upgrade to CentOS 6.

  • You're going to have to upgrade or see if the program can be compiled against the older glibc in CentOS 5 – ewwhite Mar 22 '12 at 1:23
9

Hmm. glibc 2.5 is a dependency on pretty much everything in CentOS5. If you change it to glibc 2.7, your box will explode.

Here's some discussion over in the CentOS forums:

https://www.centos.org/modules/newbb/viewtopic.php?topic_id=28345&forum=41

https://www.centos.org/modules/newbb/viewtopic.php?viewmode=flat&topic_id=27133&forum=38

0

I ran into this issue a couple times, most recently while back using Snort. Attempting to upgrade to 2.7 will.definately blow up yourto box. I rendered my test system unbootable when I tried this previously. Your best bet is to upgrade if at all possible. Failing that many applications can be recompiled against glib 2.6. If you have to deal with a no install from source on your production infrastructure take a look at how to build RPMs. A lot of products either include a spec file or there is one publically available.

  • Did you have a problem with your keyboard when writing the first part? – CommunistPancake Mar 22 '12 at 2:03
  • New mobile phone. Autocorrect needs some adjustment. – Tim Brigham Mar 22 '12 at 2:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.