I am trying to get Windows Search to work on my Windows Server 2008 SP2 fileserver, so I can search in files for content.

I have added the Windows Search Service role to the server, and using the right-click properties in Explorer set some folders to "Index this location".

The problem is that neither on the server or remotely can I search in the files.

I seem to get some inconsistencies in the GUIs, for example the "Indexing Options" panel shows me just 6 locations indexed, but if I click "Modify" I see nearly everything ticked.

Indexing Options

For example, the "SeachTest" folder under "infrastructure" has the "index this location" option ticked, but the "Projects" folder does not. I assume this is why some are grey and some not, but they are all ticked. T The "SearchTest" folder contains some files that have nothing but the text PurpleOrange in it, so I should be able to find those.

So, to summarise:

  • Which locations are indexed? The ones in the "Index these locations" list, the ones ticked, or the ones not greyed-out in the list?
  • How do I get to the state where I can click in the search box and type PurpleOrange and see the files?
  • Even though this is a server OS, you might get better results on SuperUser.. But that's just a suggestion.
    – cutrightjm
    Mar 26, 2012 at 12:30
  • What are the extensions on the files failing to be found? Certain file extensions are skipped by index service. This is kind of an old KB, but the same limitations may apply to 2008. support.microsoft.com/kb/309173
    – Clayton
    Mar 26, 2012 at 14:24
  • .txt, .docx, .xlsx, .doc, .xls and .pdf. All contain just the single piece of text "purpleorange"
    – Cylindric
    Mar 26, 2012 at 14:30

2 Answers 2


Depending on what files you are trying to index, you probably need the appropriate iFilters so Windows Search can go in and actually sift through the binary contents of each file and grab out the text so it can index it.

After the iFilters are installed, go to Control Panel -> Indexing Options Click Advanced button Click Rebuild

PDF iFilters

Adobe -- http://www.adobe.com/support/downloads/detail.jsp?ftpID=4025

foxit -- http://www.foxitsoftware.com/products/ifilter/

Microsoft Office iFilters

For office 2010 and prior versions -- http://www.microsoft.com/download/en/details.aspx?id=17062

Service Pack 1 for above iFilter -- http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=26604



  • I'm not just talking about fancy documents here, this is a plain text document too.
    – Cylindric
    Mar 30, 2012 at 10:01
  • Why did this answer get the bounty? There is no sign at all that there's anything to do with an iFilters here. I specifically mentioned that this was not just to do with PDF or Office docs.
    – Cylindric
    Apr 5, 2012 at 10:42

Any errors from the search service in the application event log? The "search contents" option appears in a couple places. Within Folder Options, and also the Search Service control panel. In the control panel, each file type has it's own option to control content search. Contents of PDF are not searched by default, you'll need to turn that on. I think it was on for the others by default, but you should verify. Or maybe go with Folder Options "always search names and contents". However, I think "Folder Options" settings may apply only to local explorer instances, and for your remote search scenario, you probably need to stick with Search Service Control Panel for all options (folders to be indexed, extensions, index method (properties/contents)).

enter image description here

I'm not using this on a server with much data, can't reproduce your problem. As a last resort, you might want to stop search service, purge the contents of C:\ProgramData\Microsoft\search\data, then restart the service and re-configure the search service options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.