0

I have a Linux/Ubuntu DLL that depends on libboost_thread-mt.so.1.38.0. I've tried various ways including building my own version of LibBoost 1.38.0 yet none of my methods have worked. I was wondering if 1.38.0 is available pre-compiled on earlier versions of Ubuntu or if my architecture (64 Bit) is not compatible with LibBoost. Does anyone have any pointers on how to fix this error?

  • This should probably be on Stackoverflow, but have you tried "boost1.38" or "libboost1.38" or similar? – gparent Mar 23 '12 at 16:21
  • Or try adding -dev as well. There should also be specific packages for the threading library, filesystem and what not, and one that includes everything. – gparent Mar 23 '12 at 16:35
1

Normally when you are trying to compile against a library on Linux or any other UNIX with gcc or various other compilers the following flags need to be set:

-L<location of the library> -l<library name>

<location of the library> could be /usr/lib, /usr/local/lib or any other directory that library may be located in <library name> is in your case: boost_thread-mt

If you are doing this on Ubuntu and you have installed boost 1.38.0 from packages there should be a corresponding -dev package that installs all things that you need to be able to compile your code with that library.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.