I am trying to use a Public Dataset with the snapshot id of snap-­e1608d88. I am looking at these instructions, but they do not seem to help.

The first suggestion there says I should click on Volumes and create a new volume, set it's size and availability zone, as well as specifying the snapshot id. The problem is, snapshot id is a dropdown, not a text field, and there are over 100 options in the dropdown.

Next I installed the ec2 command line tools and tried to run the ec2-create-volume command. For my first attempt I tried ec2-create-volume --snapshot snap-­e1608d88 --availability-zone us-east-1 but that gave output indicating I need to provide a certificate with the --cert switch. Which certficate exactly? I tried my SSH cert at ~/.ssh/id_rsa. No dice. I got the following Java error: "org.codehaus.xfire.fault.XFireFault: General security error;"

  • I'm not sure why they would provide a dropdown for the snapshot id, it's just bad UI design IMO. – the0ther Mar 25 '12 at 16:42
  • While I will concede that it isn't the best design, it shouldn't be more than a minor inconvenience. In most programs, the 'dropdown' list will select the first item that starts with the characters you type when it is selected (tested with Firefox and Chrome - but should work elsewhere). Click the dropdown for snapshot, and type 'snap-e16' and the correct entry will be highlighted (note you have to type it without pauses). – cyberx86 Mar 25 '12 at 17:32

I don't understand your confusion about specifying the snapshot ID via the web interface; the instructions don't say "type in" the ID, it merely says "Configure the following settings" -- and yes, the pulldown can contain a lot of entries.

For the certificate on the command line, it's not your SSH key it wants, it's your AWS certificate, which you can find out all about at http://docs.amazonwebservices.com/AWSSecurityCredentials/1.0/AboutAWSCredentials.html#X509Credentials


In order to get past this security error, I have created a X.509 certificate on my AWS account. I copied the new certificate to my server and passed the command line argument my new certificate, still no luck. Finally, I have uploaded the private key which was generated at the same time as creating the X.509 cert. I passed this on to the command line using the --private-key switch, and I am no longer getting a security error. But another error, this one complaining about the snapshot id that I am using.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.