1

I am trying to install mod_security from source. when i run ./configure I get this error:

configure: error: libxml2 is required

After that error, I executed this command:

yum install libxml2

It installed libxml2 properly. However, I'm still getting the same error from ./configure. How can I resolve this error?

  • In another question you mentioned using CentOS. Why are you installing from source when you could have just done yum install mod_security? – Burhan Ali Apr 6 '12 at 19:33
4

When you build software, you need the library development package, not the shared library package. So, install libxml2-devel and your build problems should go away (or at least the error message will change).

  • Thank You Sir. it worked and mod security configured. thumbs up for you. – Kashif Mar 25 '12 at 19:49
0

I don't know how to fix your compile problem, however there is an RPM for mod_security available here: http://download.fedora.redhat.com/pub/fedora/linux/development/source/SRPMS/mod_security-2.5.7-1.fc11.src.rpm

  • That particular RPM may not work, given that the OS and version being used wasn't mentioned. – Burhan Ali Apr 6 '12 at 19:30

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.