In my server setup there are three virtual machines. One windows machine, an Ubuntu Server 11.10 and a Debian Squeeze mailserver. On the Ubuntu system I have Roundcube installed and I want to connect to the virtual mail server.

What's the problem After login into Roundcube it says "Server Error (OK!)" and lists no messages.

More information On the Ubuntu server there is no error in any log file (even Roundcubes log files). In the imap log file there you can see Roundcube is able to fetch all imap messages (I can see them in the imap log file created by Roundcube). And on the side of the mail server there are no error messages too. The test connection at the end of the configuration of Roundcube works too, there is a "success" notification. Even the basic login at Roundcube login dialog works without any error message.

Roundcube log file you can look here for the log file: http://fixee.org/paste/wxg36eh/

So does anyone know what's wrong with Roundcube?


A wild guess: your PHP is configured with too tight RAM limits and that causes the Roundcube havoc. Yes, typically hitting the PHP memory limit should throw you a PHP error, but you never know...

| improve this answer | |
  • Unfortunately it's not a PHP error but a Roundcube one. And my memory limit is set to unlimited yet. – thonixx Mar 27 '12 at 10:00

Ok problem half-solved:

I just removed libapache2-mod-php5filter and instead of that I installed libapache2-mod-php5. I don't know whats wrong with that but that solved my problem. I even don't know why I installed filter instead of handler.

| improve this answer | |
  • This answer totally broke my roundcube installation. – Kees de Kooter Apr 26 '12 at 20:32
  • What's your main problem with Roundcube? Same error "Server Error (OK!)". – thonixx Apr 26 '12 at 21:52
  • Yes. I guess removing phpfilter messed up my apache-php installation. – Kees de Kooter Apr 27 '12 at 6:37
  • Try to delete everything related to apache2. sudo apt-get remove apache2 php5-mysql libapache2-mod-php5filter libapache2-mod-php5 and then you can reinstall it with sudo apt-get install apache2 libapache2-mod-php5 – thonixx Apr 29 '12 at 20:47

I had the same problem and after reading the doc, I found that it's helpfull to activate some apache modules :

a2enmod deflate
a2enmod expires
a2enmod headers

A restart of apache2 and roundcube works like a charm and the server is running with php5filter.

| improve this answer | |
  • Can't prove solution. – thonixx May 22 '13 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.