I was connected into our SBS/2008 Server via RDC (on Windows 7). I wanted to install Terminal Services since we have the CALs and the 2 max concurrent users (administrators) was restrictive.

So I installed the Terminal Service, Terminal Licence Service, and Terminal Service Gateway roles. It would not let me configure this before I restarted (it would error if you launched the MMC consoles on the machine).

After the machine restarted, not only could I NOT connect to Terminal Services but I also am unable to connect to RDC. I am still able to connect via MMC/IIS but that only gives me basic tools like Services, Computer Manager, etc.

Is there a way to remotely uninstall Terminal Services or alternatively a way to fix this so I can RDC into this machine? At the moment the RDC client just gives me a generic "cannot connect" error.


rdc is a limited subset of terminal services (see comment below for clarification), they aren't separate products, so my guess is that ts install stepped over some configuration or firewall directive and that's why you can't connect.

If you have mmc access, download the remote server admin tools, http://www.microsoft.com/download/en/details.aspx?id=7887 (that link is for windows 7) and mmc into it. you'll be able to manage roles and features on your server and remove TS. you should also check the event log to see if the problem is registering there.

if you want to have ts installed and can't access the machine locally and this problem is due to an install default setting for ts, then install another remote client like vnc or logmein or whatever before adding the ts roles.

  • While I generally agree with your answer, I have to take umbrage regarding your statement about RDC, as it is not a limited subset of TS/RDS. Remote desktop for administration connections and TS/RDS both use the same underlying protocol, one is not a subset of the other. The difference is in how user sessions and software instals are handled, as well as the TS/RDS CAL requirement for running TS/RDS. – joeqwerty Mar 27 '12 at 16:07
  • yeah after rereading it I realized that was not the proper way to put it, but didn't quite know how to make the distinction. thanks for the correction – Nicolás Straub Mar 27 '12 at 16:09
  • Glad to help. + 1 for the answer. – joeqwerty Mar 27 '12 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.