1

I'm trying to set-up the fresh phpMyAdmin install on my Debian 6 server to use http authentication rather than the cookie based auth that is default when it is installed.

To do this, I edited the $cfg['Servers'][$i]['auth_type'] line to use 'http' as its setting in /etc/phpmyadmin/config.inc.php, and restarted the server, but the setting seems to be being ignored, as when I goto phpmyadmin, it is still offering up the regular login box.

I've done this twice before (once on debian and once on ubuntu), so I'm not sure why it isn't working this time.

Thank you

0

On Debian 6, I just edited /usr/share/phpmyadmin/config.inc.php which holds the defaults.

I changed

if (!isset($cfg['Servers'][$i]['auth_type'])) {
    $cfg['Servers'][$i]['auth_type'] = 'cookie';
}

to

if (!isset($cfg['Servers'][$i]['auth_type'])) {
    $cfg['Servers'][$i]['auth_type'] = 'http';
}

There's a big header in that file warning you not to edit it but, you know, it worked! I'm awaiting all the reasons why you shouldn't do what I did.

  • Alas, this isn't the answer that I wanted - but it is the one that has worked. Maybe there is an issue with debian's phpMyAdmin config, because the advice to edit /etc/phpmyadmin/config.inc.php rather than /usr/share/phpmyadmin/config.inc.php clearly doesn't work. – Daniel Hollands May 21 '12 at 15:53
  • "why you shouldn't do what I did": because after the next upgrade to phpMyAdmin all your settings will be lost. – ntd Nov 4 '15 at 7:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.