3

I have a web server setup with postfix which is relaying email to a zimbra server. This working fine however I have attempted to send a few thousand emails and now the connection from postfix to zimbra is timing out. All of the emails have been deferred on the postfix queue.

If I try to send individual emails from postfix to zimbra it works fine. But if I try to flush the postfix queue all of the emails time out. In mail.log the emails look like this:

postfix/error[2494]: 32B0950C04: to=, relay=none, delay=19431, delays=19402/29/0/0.01, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to mail.server.com[123.45.678.91]:25: Connection timed out)

I have also noticed that in the above message it says "relay=none" for these emails that are failing. But the emails that do send say "relay=domainname.com".

How I can resolve this, by sending the emails in the queue and avoiding this from happening again?

1
  • I have same issue, if your zimbra behind firewall and point to local IP (was NATed for Global IP mail.server.com[123.45.678.91]), you have set zimbra known that don't look at DNS. I think you will get hints from following URL: wiki.zimbra.com/wiki/Incoming_Mail_Problems Good Luck. NgMDat
    – NgM Dat
    Commented May 6, 2018 at 12:15

2 Answers 2

2

It sounds like you're overloading your Zimbra server, to the point that it can no longer handle incoming requests.

You need to look at your Zimbra server and analyze it to see where the performance bottleneck is. You may also benefit from general performance tuning.

1
  • Thanks. You are probably right. It is running on a cloud instance with only 2gb of memory. When this problem occurs emails in the thousands are being sent at once.
    – liamTc
    Commented Feb 4, 2013 at 22:39
0

connect to mail.server.com[123.45.678.91]:25: Connection timed out)

This means that the mail was originally addressed to that server.

If this was incorrect, you need to explicitly re-queue the messages using

postsuper -r ALL

This causes the destination to be calculated anew.

2
  • It isn't incorrect. Because the IP address is always the address of the Zimbra server which is used to relay.
    – liamTc
    Commented Mar 29, 2012 at 23:19
  • Then you need to fix the zimbra server, no?
    – adaptr
    Commented Mar 30, 2012 at 8:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .