I am trying to build ntgs from the latest source, using the .spec from rpmforge - as non-root via rpmbuild. During the compile, it fails at this step:

checking for GNUTLS... no
configure: error: ntfsprogs crypto code requires the gnutls library.
error: Bad exit status from /var/tmp/rpm-tmp.78913 (%build)

However, I can compile it successfully outside of rpmbuild. So it sounds like it just the matter of library being seen during the build. However, I can confirm that rpmbuild can see the library that gnutls resides:

[foo@bar ~]$ rpmbuild -E '%{_libdir}' rpmbuild/SPECS/ntfsprogs.spec 

Library location:

[foo@bar ntfs-3g_ntfsprogs-2012.1.15]$ /sbin/ldconfig -p | grep -i gnutls
        libgnutls.so.13 (libc6) => /usr/lib/libgnutls.so.13
        libgnutls.so (libc6) => /usr/lib/libgnutls.so
        libgnutls-openssl.so.13 (libc6) => /usr/lib/libgnutls-openssl.so.13
        libgnutls-openssl.so (libc6) => /usr/lib/libgnutls-openssl.so
        libgnutls-extra.so.13 (libc6) => /usr/lib/libgnutls-extra.so.13
        libgnutls-extra.so (libc6) => /usr/lib/libgnutls-extra.so

What would cause the problem of the library not being seen when you build a RPM?

EDIT: Oh yeah, I am running Centos 5.5.

  • Run this as your rpmbuild user to see where your library is installed: /sbin/ldconfig -p | grep -i gnutls – Kyle Mar 30 '12 at 16:16
  • Updated with output. – Rilindo Mar 30 '12 at 18:26

Version 2012.1.15 of ntfs-3g_ntfsprogs requires gnutls >= 1.4.4 but RHEL5 only provides 1.4.1. You were able to compile it outside of rpmbuild because you didn't specify --enable-crypto in your configure which the spec file does. These problems can be identified by examining config.log.

In general, handling a version bump of this magnitude--in this case from 1.13.1 (Feb 22 2007) to 2012.1.15--will be more involved that simply editing the "Version:" line in the spec file.

Also note that the EPEL repo has version 2011.4.12 ( http://dl.fedoraproject.org/pub/epel/5/x86_64/repoview/ntfsprogs.html ) which may be new enough for you. If you have already installed rpmforge packages on your system I urge caution as rpmforge and EPEL do not work well together.

  • Ah, okay. Looks like it is going to be a lot more work for me. :| Thanks! – Rilindo Apr 3 '12 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.