I am migrating some web apps from a windows 2003 server with IIS6 server to a Windows server 2008 R2 server with IIS7.

One of the apps, which runs on asp.net v2.0 using forms authentication will not load.

It gives me the following error...

The specified module could not be found. (Exception from HRESULT: 0x8007007E)

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.IO.FileNotFoundException: The specified module could not be found. (Exception from HRESULT: 0x8007007E)

Now i fully understand that the app cannot load some kind of resource due to a FileNotFoundException, but i am struggling to diagnose exactly where in the application this is happening, as it does not tell me what the module is, nor what file it is looking for.

I have enabled failed request tracing and i get back a complete request trace, yet i cannot find anything that gives me detail on this specific error, or the module involved.

Here is a log (and the xsl sheet) from a failed request...

XML Log File

XSL Stylesheet for log file

Download both to your machine and open the xml file.

Any advice on diagnosing the root cause of the issue would be greatly appreciated.

  • can you please upload the generated request trace so we can have a look at it?
    – Thor Erik
    Mar 31, 2012 at 10:20
  • What was the app pool configuration for it on the IIS7 host? Have you tried running it as ASP.net 2.0 Classic(obviously change the app pool it runs under)?
    – Thor Erik
    Mar 31, 2012 at 14:33
  • same error under classic mode. going to dig in with process monitor as per Gregs post.
    – Baldy
    Apr 1, 2012 at 9:42

1 Answer 1


I've seen this occur before where a referenced managed assembly is present on the previous machine (such as in the GAC or registered in another location), but is not present on the new machine.

If you can identify the missing managed assembly(s), one approach may be to configure them to "copy local" so that they are "bin-deployed" to the application bin folder.

You may want to try running SysInternals' Process Monitor to identify the missing assembly.

There have also been a few occurrences where native assemblies were missing from the %systemroot%\system32 folder, such as msvcr71.dll.



  • This is the thing Greg - i Need to find out what module it is. I'm very new to process monitor but one of those posts you link to should help me on my way. Thanks!
    – Baldy
    Apr 1, 2012 at 9:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.