0

I'm trying to install sphinxsearch on a Virtual Private Server that is running Debian GNU/Linux. It seems to depend on upstart-job. Here is the output I get when I try and run the installer.

[ps64518]$ sudo dpkg -i sphinxsearch_2.0.4-oneric_amd64.deb
Selecting previously deselected package sphinxsearch.
(Reading database ... 149083 files and directories currently installed.)
Unpacking sphinxsearch (from sphinxsearch_2.0.4-oneric_amd64.deb) ...
dpkg: dependency problems prevent configuration of sphinxsearch:
 sphinxsearch depends on upstart-job; however:
  Package upstart-job is not installed.
dpkg: error processing sphinxsearch (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:
 sphinxsearch

When I then try to install upstart sing apt-get I get the following output:

[ps64518]$ sudo apt-get install libnih1 libnih-dbus1 upstart
Reading package lists... Done
Building dependency tree   
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 upstart : Conflicts: sysvinit but 2.88dsf-13.1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I traced that conflict to a question at https://unix.stackexchange.com/questions/6042/upstart-on-debian, which seems like a pretty extreme measure to install sphinxsearch. Am I doing something wrong? Can anyone please advise me on how to install on my production server? It worked with no problems whatsoever on my Ubuntu 11.10 development laptop.

  • I deleted my answer, as I failed to notice that this is Debian - not Ubuntu. Sorry about that. – pauska Apr 1 '12 at 18:31
1

Forget installing using dpkg - it's much easier to just build from source and run searchd yourself. That worked much better for me.

  • This is exactly how I would have answered. – Hawkee May 6 '12 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.