2

For a while I've been getting this error while doing anything apt-get related:

Preparing to replace python-cairo 1.4.12-1.2 (using .../python-cairo_1.8.8-1+b1_i386.deb) ...
Traceback (most recent call last):
  [...]
  File "/usr/share/pycentral-data/pyversions.py", line 172, in default_version
    raise ValueError, "/usr/bin/python does not match the python default version. It must be reset to point to %s" % debian_default
ValueError: /usr/bin/python does not match the python default version. It must be reset to point to python2.6.6

Whereas

robus:/# /usr/bin/python -V
Python 2.6.6

How do I fix this? I did try fixing symlinks, but then I keep getting 'too many symlink levels' errors.

2

I'm a bit surprised that it requires python2.6.6 and not python2.6 (for packaging purposes only two-part version numbers are usually used). This seems to come from /usr/share/python/debian_defaults, which on my system contains default-version = python2.7. What does the default-version line in your file contain, and has this file been changed at all on your system?

| improve this answer | |
  • default-version = python2.6, used to be 2.6.6 I believe – Robus Apr 13 '12 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.