3

I have a bunch of Windows 7 laptops connected to WiFi (WPA2 PSK).

When the user logs-in, the connection is automatically created (the connection profile is saved). But when the user logs out, the connection is automatically closed. Is there any way to keep the connection (until somebody connects to different network)?

  • Is it possible to use this connection before anyone is loged in? So that the users can be verfified in the domain by the wireless network? – user192348 Oct 2 '13 at 12:16
  • same issue, did you find an answer? – Damainman Feb 11 '15 at 18:44
  • Not directly. After some update or something it started working itself. :\ – cincura.net Feb 12 '15 at 7:10
2

If the network connection has been saved for 'All Users' then it should connect when the wireless is enabled, regardless of whether anyone is logged on.

If you open the network and sharing center, go into Manage Wireless Networks, right-click the network and choose properties, you'll see the 'Network Availability' - is that set to All Users?

  • 1
    Yes, double checked, 'All Users'. – cincura.net Apr 3 '12 at 16:10
  • Not working for me. Could it be due to security type being WPA2-Enterprise? – Nikola Malešević Aug 21 '15 at 11:13
  • Remove the connection. Log in as admin user. Create the connection. Make it available to all users, but disallow all users from modifying the connection. – Xalorous Oct 5 '16 at 16:39
2

If the setting mentioned is set to all-user profiles and Wifi is still dropping, you may need to log into an admin account and connect to the network. One of our machines at work would disconnect when switching users, making remote control difficult as the user had standard user rights. What I did was log in as admin when I was local to the machine and connected to the WiFi network in the admin account. Now, I can switch users over remote control.

0

The network should be set to All Users, but it may also be necessary to save the authentication for access to the wifi network. This is intended by Microsoft to allow updates when no one is logged in. When the auth setting is (user or computer) it is not possible to save auth info. Try the following:

Control Panel\Network and Internet\Manage Wireless Networks; Manage wireless networks; On the desired network, RClick, select Properties; Security Tab; Advanced settings; Specify auth mode as "User authentication"; use the "Save settings button" and reenter login info; OK out of all;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.