A funny thing happened this afternoon.

After a restart of my home server (that I use as a testing environment for websites and as a backup for files on the other computers on the network) which is running Server 2008 R2, I am now unable to access the server or any of the shares on the server from any of the other computers on the network.

I was able too before, I haven't to my knowledge changed anything to contribute to this happening. I have reset the server numerous times since, as well as reset the router and the other computers on the network, which appears to have done nothing.

I can still remote desktop the server and ping it via its internal IP address and the computer name, however I cannot access it in the network explorer or the mounted network drives on the other computers (it still shows up in the list of computers in "Network" (windows 7 PC's)).

I have checked the permissions on the shares to make sure they are not the culprit, they all appear to be fine.

Any ideas why this may have suddenly happened and what might be the fix(es)?

Thanks for any help anyone can give.

  • What happens when you try and access the mounted drives? Error messages? Also open a command prompt and type NET VIEW \\Servername and see what you get back. Apr 3, 2012 at 7:31
  • I tried the cmd command you suggested below is the output:
    – Neaox
    Apr 3, 2012 at 7:51
  • Shared resources at \\Server Share name Type Used as Comment ------------------------------------ Share Disk T: [Offline Share] The command completed successfully.
    – Neaox
    Apr 3, 2012 at 7:52
  • You haven't answered my first question about any error messages you receive when trying to access the shares :-) Also check that network discovery hasn't been disabled on the server, and that the firewall isn't blocking the traffic. If your server is behind a perimeter firewall, it should be safe to temporarily turn the server's firewall off completely to test whether this is the cause. Apr 3, 2012 at 8:10
  • On the computer I am on now it gives no error as I have 'always available' offline files that are stored on the server (user profiles). On other computers on the network it gives the error "windows cannot access //Server check the spelling of the name..." I tried disabled the windows firewall this does not fix the problem :( Network discovery is enabled on the server and every computer on the network. Thanks for the suggestions :D
    – Neaox
    Apr 3, 2012 at 9:29

3 Answers 3


Fixed it. I fixed it by uninstalling the "File and Printer Sharing for Microsoft Networks" on the network adaptor, reinstalling it and then restarting the computer. After the re-start things are now back to normal.

To uninstall the "File and Printer sharing for microsoft networks" in windows 7/Server 2008:

  1. Go to Network and Sharing Center from the control panel.
  2. Click change adaptor settings on the left hand side.
  3. Right click the network adaptor (if you have more than one you may need to do this on all of them).
  4. Select "Properties" from the list.
  5. In the "This connection uses the following items:" select "File and Printer Sharing for Microsoft Networks".
  6. Click the "Uninstall" button.
  7. Click "Yes" when the conformation box appears and wait for it to uninstall ("File and Printer Sharing for Microsoft Networks" will disappear from the "This connection uses the following items:" box once uninstalled).
  8. Click the "Install" button.
  9. Select "Service" from the "Click the type of network feature you want to install:" box.
  10. Select "File and Printer Sharing for Microsoft Networks" from the "Network Service" box.
  11. Click "OK" and it should install in less than a few seconds ("File and Printer Sharing for Microsoft Networks" will reappear in the "This connection uses the following items:" box once installed).
  12. Restart the computer and the problem should be fixed.

Thanks for all the help and suggestions everyone.


Have you try to look at the ACL of the share folder? Maybe your last manipulation and the reboot screwed up your ACL (Happen to me once, on a production server.) If it's what happen, you'll need to recreate the ACL (for that I use a powershell script, fast and clean :).

Hope this help.

  • I only have a vague idea of what you just said. Would you mind talking me through how to confirm if this is the case and exactly what to do to fix it? Thanks for your help.
    – Neaox
    Apr 3, 2012 at 7:04

It's very simple in my case. All the users Accessing Shares Files Using "It" user name , I just delete it and create it again including "Full Name , description" and resting with New Password.

Not the answer you're looking for? Browse other questions tagged .