How do i disable the notifications of particular errors?

A little background to my issue. During the installation of the Kaspersky, it disables all the windows firewall for all except the domain. I have remedied this by creating an offline policy in Kaspersky which enables the Kaspersky firewall when out of the office (ie not connected to the office network). The problem now is that users in the office now see a notification showing that the firewall is disabled even though it’s enabled in all scenarios. It’s just that work and home show as disabled when the clients are connected to the office LAN. I’ve looked into the notifications and you can disable the notification (not recommended) but I don’t want to do this incase other relevant messages are stopped from being displayed.


| improve this question | | | | |
  • You would need to ask the developers of the kaspersky. – Rob Moir Apr 3 '12 at 14:33
  • All I want to do is disable the "windows" feature that displays a issue with the firewall. Kaspersky disables the firewall "public and private" but the clients are protected at all times so there is no problem. – resolver101 Apr 3 '12 at 14:58
  • Well no, you don't want to disable the feature that displays an issue with the firewall, not according to your question anyway. You want Windows to magically understand whether or not you think a message about the firewall is a good message or a bad message, then decide what to display based on that. Which isn't quite the same thing. – Rob Moir Apr 3 '12 at 16:43
  • I'm happy for any Firewall issues to be ignored by Windows. I trust Kaspersky to keep our firewall working. Does that clear up my requirements? – resolver101 Apr 4 '12 at 10:41

Kaspersky should register as firewall in windows, so the action center is clean without manual intervention.

What is your version of Kapersky ? Check it does fully support Windows 7

| improve this answer | | | | |
  • Im on endpoint security 8. The server side is securuity centre 5. We are running Windows 7 profesional on the clients and the server is windows 2008. The link below shows Kaspersky supports windows 7 profesional kaspersky.co.uk/koss-2_system_requirements – resolver101 Apr 4 '12 at 8:39
  • Your link is not version specific. Is security 8 the last version from Kapersky ? – Mathieu Chateau Apr 4 '12 at 12:55
  • +1, that would indeed solve the problem and not band-aid a symptom (even though the OP is asking for a band-aid, probably b/c the cure isn't readily available), AVG registers its firewall. – MDMoore313 Sep 6 '13 at 19:01

There's only one group policy to do this, and it affects the entire action center, not just the firewall notifications, but if that's OK with you, then you should use it.

User Configuration\Administrative Templates\Start Menu and Taskbar
Remove the Action Center icon
Minimum Windows: 7 or 2008 R2

If you want to get deep into the registry, you can use the new Preferences control to define your own registry key, using:

Key: Software\Microsoft\Windows\CurrentVersion\Action Center\Checks\{E8433B72-5842-4d43-8645-BC2C35960837}.check.100
Value: CheckSetting
Action: Update
Data: hex:01,00,00,00,d0,8c,9d,df,01,15,d1,11,8c,7a,00,c0,4f,c2,97,eb,\

It's not pretty, but it works. Besides a GP Pref, you can also apply it with a login script. {E8433B72-5842-4d43-8645-BC2C35960837}.check.100 is the built-in Windows Firewall, check.101 and up are additional third-party firewalls.

The registry keys in this folder are the ones that get changed when a user clicks "Turn off messages about (whatever)." in the Action Center.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.