I have a couple VMWare ESXi 5 servers, and on both of them I am unable to take a snapshot of one of my virtual machines (have tried moving the vm from one to the other). I am able to snap shot other machines.

I see an error within a few seconds in the vSphere Client: Create virtual machine snapshot mymachine File mymachine/mymachine.vmx is larger than the maximum size supported by datastore '[2TB_1]

The data store consists of 1 2tb sata drive and has plenty of space (1.7TB free). The vm in question, vmdk file is just over 8gigs. All other files in it's directory as less than 1mb.

The datastore is VMFS 5.54, maxium file size 2.00TB, Block site 1MB (was originally setup this way, not converted from old version).

All the files in the vm folder look like the proper name "mymachine.xxx" (vmx/vmf/vmsd/nvram/vmdk).

Machine is powered off (was logically shut down). The guest is Windows Server 2008r2.

When I tell it to take a snapshot, it looks like it modifies the vmsd file based on it's modified date/time, but that's it.

Any ideas?

I have tried adding some parameters for workingDir and snapShotRedoNotWithParent per these pages and no difference: one two three

Also found a page mentioning that either the block size is not 1mb or the vmx is in a different directory than the vmdk - neither is true in this case.

Also, I even tried cloning the machine (to make sure all the files are named properly/the same and in the same directory), which worked fine, but the new clone will not snapshot, same error.

Here is what my datastore configuration looks like:

This is where the vmx / vmdk file is stored: 2TB_1 Normal Local ATA Disk (t10.ATA_____ST2000DL0032D9VT166__________________________________5YD2HR2E):1 Non-SSD 1.82 TB 1.55 TB VMFS5 4/22/2012 10:08:05 AM Enabled Disabled Not supported VMFS 5.54 Maximum File Size 2.00 TB, Block Size 1MB

this is the boot drive for vmware: datastore1 (1) Normal Local ATA Disk (t10.ATA_____Patriot_Pyro____________________________PT1131A00007123_____):3 SSD 51.00 GB 50.05 GB VMFS5 4/22/2012 10:08:05 AM Enabled Disabled Unknown VMFS 5.54 Maximum File Size 2.00 TB, Block Size 1MB

here is a pic of the vm's directory (after a fresh clone):

picture of the vm directory

  • What's the size of the virtual disk? If you browse the datastore, how large does "mymachine.vmx" appear?
    – Jim G.
    Apr 4, 2012 at 4:10
  • Its just under 3k (the vmx file) -- the vmdk is just over 8 gigs. Apr 4, 2012 at 15:16

1 Answer 1


I came across the solution by chance - I right clicked on the vm and chose snapshot -> consolidate (even though there are currently no snap shots in the snap shot manager) and now it's fine. Now I can create a snap shot, delete, create a new one, etc. So consolidate fixed it.


later, my snapshots were failing again, so I did a lot more research and finally, I believe I have the answer. It's because my VMDK (virtual disk) size is set to 2TB! Reading through this post, I thought maybe it's because my vmdk is defined as 2TB, and my physical datastore disk is only 1.9TB. I would think it should not be an issue, since it's thin provisioned, but in fact, after using vmware tools to copy the machine and make the disk smaller (1.5TB) (other methods here for shrinking the disk here) everything seems to work working fine now!

  • update: my backups were failing again, so I tried my 'consolidate' trick, and it's not working to fix it this time! Same error as described above. So I am still stuck, I am not sure why I am unable to create a snapshot of these 2 machines. 2 others on the same box are fine! Apr 22, 2012 at 13:16
  • Something basic is wrong here... some screenshots of your configuration would go a long way. Let's have a look at your storage screen with the datastore in question highlighted Apr 22, 2012 at 13:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .