Okay, we have a web server, that serves up a whole bunch of sites. Numerous of our sites serve up zip files, without any issue.

On one site however, it refuses to serve them up. The file names are longerish (though not really long by any imagination) ... for example: 01-EXPORT-20120403.121040.zip. I thought maybe it had issues with the length or with the format of the filename, so I tried changing one of them to just zip.zip ... but it still wouldn't serve it up.

In IE you get the error page: Internet Explorer cannot display the webpage
In FF you get the error page: The connection to the server was reset

I wanted to see if it was specifically zip files, so I put a dummy hello.txt file in the directory and tried browsing to that and it works fine, changed the extension to .zip and then it had the same error, so it seems to be specific to zip files.

I made sure that the mime-type is set up for zip files on the site exactly as it is on sites which successfully serve up zip files:

enter image description here

I checked the IIS server logs, and I see the entries where the file is being requested, and the server status code being logged is 200 (SUCCESS), so that didn't help me any.

I set all failure auditing ON on the file, thinking maybe it was a permissions issue, browsed, got the error, then checked the security logs on the server, but there were no failure audits.

I fired up Firebug in FF, and this is what it shows me:

enter image description here][1

But I cannot for the life of me figure out WHY the server is aborting the file.
Any ideas what or where I can look for more information to try to get it to serve up these files?

I've tried restarting IIS on the machine, tho not actually restarting the machine yet.

The IIS/Windows version is Windows Server 2003 R2.

CLARIFICATION: This is actually on one sub-directory application under a site. Yet, another sub-directory application under the same site serves zip files up fine (as well as other actual sites on the same server). Both applications (working and non-working) are running on ASP.NET 4.0.

I also thought maybe the files were too big, but I looked at the file size, and they are only like 2KB, so I doubt that is the problem.

UPDATE: I did a little more testing, it worked on a 'Classic' ASP site, so thought maybe it was only on ASP.NET sites. Tried it on a .NET 3.5 site and it worked, so thought maybe only on .NET 4.0 sites. Tried it on another .NET 4.0 site and it worked, so it is apparently not tied to .NET or to a .NET version.

  • Is this issue only happening for external connections? Or locally as well? Do you have any proxies, filters, or firewalls interfering?
    – Mike B
    Apr 3, 2012 at 17:52
  • @MikeB Thanks. I see the same problem whether I try to run it from an external machine, my development workstation or from on the server itself.
    – eidylon
    Apr 3, 2012 at 17:56
  • 1
    Looks like Zip is mapped to an ISAPI, not being served as a static file type. Edit: oh, you worked it out :)
    – TristanK
    Apr 4, 2012 at 1:50
  • Yeah, the other site, where we are serving up zips via an HttpHandler was my first time coding that particular mechanism, so it was a bit of a rookie mistake. lol . But yes, you were right! Thanks @TristanK.
    – eidylon
    Apr 4, 2012 at 3:11

2 Answers 2


Okay, I seem to have figured this out. It was actually the MIME type mapping... which I had to REMOVE.

I had added that to the site, as one of our application directories under the site uses an HttpHandler to respond to zip files and zip up set files based on parameters. For this it needed to have .zip files mapped to the ASP.NET process.

However for direct zip file downloads, it did not know what to do with them, so I removed the mime-type from the site, and added it just on the application directory's properties, and now all works.


I cannot remember exactly where, but IIS does have a mechanism for "allowed" file types. It can be global or site-specific, and there is an adjustment you must make to allow it to server a file with a certain extension.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.