I am running Ubuntu 11.10.

This is the only line in my /etc/apt/sources.list with the text "google" or "chrome" in it:

deb http://dl.google.com/linux/chrome/deb/ stable main

Sometimes (not always) when I run apt-get update, I get these warnings at the end of the output:

Reading package lists... Done
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main amd64 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main i386 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-i386_Packages)
W: You may want to run apt-get update to correct these problems

If I run apt-get update again immediately after receiving these warnings, they don't show up the second time (or third time, etc...). But then the warnings always come back eventually.

In any case, installing/updating google-chrome works fine, but those warnings are annoying (and since I skim over them now, I may inadvertently miss some more important warning if one ever comes up).

Any way to get rid of these warnings permanently?


When you installed chrome it most likely added a file in /etc/apt/sources.list.d/ named google-chrome.list. You should remove the line you manually added, and just keep the file that is in there, which is what the chrome package uses.

  • That fixed it thanks! Will mark this accepted when I can in 8 minutes :). Any idea why the warnings only showed up part of the time? – Ben Lee Apr 3 '12 at 18:01
  • Well I guess you manually added the line the first time without error, then installed the package, and then started seeing errors after chrome got installed, since it includes that file. – Zoredache Apr 3 '12 at 18:07
  • Yes, but after running apt-get a second time in a row, I wouldn't get errors the second time. Not that important, though. Problem solved is the important part! – Ben Lee Apr 3 '12 at 18:08
  • Hrm, I don't have a good answer for that. – Zoredache Apr 3 '12 at 18:13
  • 3
    OK the other problem I found its google-chrome.list with google.list files in same directory (/etc/apt/sources.list.d/). To solve it just remove both google.list + google.list.save files and leave google-chrome.list + google-chrome.list.save files. – sobi3ch Aug 13 '12 at 7:20

protected by Michael Hampton Jun 14 '13 at 17:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.