3

I am just trying to restore a mysql dump. Below are the command and error message. Can anybody give me some clues how to approach this?

10:54:16 Restoring C:\Users\matcheek\Documents\dumps\Dump20120405-1.sql

    Running: mysql.exe "--defaults-extra-file="d:\temp\tmpbvhy4i.cnf"  " --host=127.0.0.1 --user=root --port=3306 --default-character-set=utf8 --comments < "C:\\Users\\matcheek\\Documents\\dumps\\Dump20120405-1.sql"

    ERROR 2006 (HY000) at line 271: MySQL server has gone away
5
  • Is mysql servers still running? Are you restoring a huge file?
    – Khaled
    Apr 5 '12 at 10:26
  • Is there anything in your MySQL error log?
    – Ladadadada
    Apr 5 '12 at 10:27
  • It is still running, it just doesn't restore the dump. The file size is 1.5GB
    – matcheek
    Apr 5 '12 at 10:27
  • and nothing specific in the MySQL/data location, I mean I expected the error log to be there but can't see it
    – matcheek
    Apr 5 '12 at 10:29
  • The logs are usually kept in a centralized location, for example /var/log/mysql on some Linux distributions.
    – Kyle Smith
    Apr 5 '12 at 10:38
5

For benefit's of people who encounter the same error: I have followed the documentation on the error and played with a few settings. I got it working after making these changes:

wait_timeout=28800
interactive_timeout = 28800
max_allowed_packet=16M
1
  • If this solved the problem, please mark it as solved by clicking the check mark next to the answer, so that it turns green. Otherwise your question will continue to be presented as an unanswered question. Dec 25 '13 at 0:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.