I'm running Ubuntu 11.10 - setting up NFS to share a directory among many other servers. Which ports are required to be opened on the firewall?

  • 4
    It depends on the version of the protocol you intent to use. NFS 4 only require 2049 while older versions require more. – lzap Sep 11 '15 at 9:26
up vote 80 down vote accepted

rpcinfo -p | grep nfs

Port 111 (TCP and UDP) and 2049 (TCP and UDP) for the NFS server.

There are also ports for Cluster and client status (Port 1110 TCP for the former, and 1110 UDP for the latter) as well as a port for the NFS lock manager (Port 4045 TCP and UDP). Only you can determine which ports you need to allow depending on which services are needed cross-gateway.

  • 4
    I did not know about rpcinfo, that is quite useful. I didn't see the port 111 with the grep nfs, but I left off the grep to learn that 111 is for portmapper. Also good to know! (and like you mentioned, necessary) – kenny Apr 5 '12 at 21:12
  • @KennyYounger rpcinfo is a useful too. If this answered your question, don't forget to mark it as the answer for the benefit of future viewers. – Wesley Apr 5 '12 at 21:17
  • 4
    You need mountd open when you first mount the filesystem. It runs on a dynamic port, so it won't always be the same. I put a link to a guide in my answer. – bonsaiviking Apr 5 '12 at 21:23
  • @bonsaiviking Excellent! Thank you. – Wesley Apr 5 '12 at 21:33
  • Thanks @bonsaiviking. Critical info for this process. I upvoted your answer! – kenny Apr 6 '12 at 0:25

In addition to 111 for portmapper and 2049 for nfs, you will need to allow the mountd port and possibly rquotad, lockd, and statd, all of which can be dynamic. This excellent NFS security guide recommends changing your startup scripts and kernel module configs to force them to use static ports.

In addition to the guide above, which has a section on firewalls, see my answer to another question about hardening NFS.

  • 7
    We really do prefer content, not pointers to content. A précis of the content with a link is ok too and preferred to a link. – Iain Apr 5 '12 at 21:31
  • 2
    Not sure about 2012 but the recommendation in links seems to be grossly outdated. NFS over TCP is preferred for variety of reason and NFS over UDP can cause silent data corruption on fast link due to protocol limitations. Security guide has no mention of Kerberos/GSS etc. – Maciej Piechotka Dec 26 '16 at 16:46

I found useful directions for my problem on this page, but there was no easy to follow recipe. So here's my recipe.

TL;DR - need to allow both nfs ports (111, 2049) and mountd port after fixing it.

Instructions:


Setting up a fixed port for mountd

gksudo gedit /etc/default/nfs-kernel-server
  • comment out this line: RPCMOUNTDOPTS=--manage-gids
  • add this instead: RPCMOUNTDOPTS="--port 33333"

Or any other port number.

now try to reset nfs using:

sudo service nfs-kernel-server restart

And test if it helped using:

rpcinfo -p | grep tcp.*mountd

For me it wasn't enough, but a full restart fixed the issue.

(credit)


Setting up the firewall

(1) delete old rules, do this manually or reset if this is the only use for the firewall:

sudo ufw reset
sudo ufw enable

(2) add nfs & mountd ports

sudo ufw allow in from 10.0.0.1/20 to any port 111 
sudo ufw allow in from 10.0.0.1/20 to any port 2049
sudo ufw allow in from 10.0.0.1/20 to any port 33333

(Change to your local IP's or to "any" instead of 10.0.0.1/20)

That's all there's to it.

  • 1
    You don't need to restart the entire box. A simple sudo service nfs-config restart before restarting the nfs-kernel-server will do just fine. – showp1984 Feb 27 '17 at 23:29
  • @showp1984 thanks, I'll try that next time – auval Feb 28 '17 at 5:57

With FERM one can use Backticks to get the ports from rpcinfo, for example:

Server:

proto tcp {saddr ($CLIENT) {
  dport (`rpcinfo -p | perl -e 'while(<>){/\s+\d+\s+\d\s+(?:tcp)\s+(\d+)/ and $ports{$1}=1}; $, = " "; print sort(keys(%ports)),"\n"'`) ACCEPT; # NFS
}}
proto udp {saddr ($CLIENT) {
  dport (`rpcinfo -p | perl -e 'while(<>){/\s+\d+\s+\d\s+(?:udp)\s+(\d+)/ and $ports{$1}=1}; $, = " "; print sort(keys(%ports)),"\n"'`) ACCEPT; # NFS
}}

Client:

proto udp {saddr ($SERVER) {ACCEPT;}}  # NFS

(If you're only going to use the TCP then you need only the proto tcp part).

This will give a list of all ports used by all NFS-related program:

rpcinfo -p | awk '{print $3" "$4}' | sort -k2n | uniq

For the records, I had to add permissions for ports 111, 2049 AND 1048 for a configuration where an NFS share is exported by a Windows 2008 R2 server and the clients are Ubuntu 12.04.4.

I hope this helps someone.

  • 2
    It might help to explain why you needed port 1048 and how you determined that. – HBruijn Dec 16 '15 at 10:48
  • 3
    Frankly, I don't have a clue why I needed to add a permission for 1048, but adding that solved my problem. I just wanted to share if that can save time someone else in the future. I am sorry for not being able to answer the question. – Erdem KAYA Dec 20 '15 at 10:33

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.