Background: I recently got a Windows cloud VPS server. I don't have much experience with server admin (I'm a programmer), and what little I do have is with linux servers.

Ever since getting the server I've been having issues with RDP. I can connect about two or three times, after which point I can't connect until one of the tech guys "fixes" it (see below). When I connect, I can stay connected for hours with no problem.

When the problem connecting starts, the first time I try to log in, the remote desktop window pops up, starts connecting, and then exits with "Your Remote Desktop session has ended". After that, for about 10-20 minutes if I try to connect again, the connections times out with

Remote Desktop can't connect to the computer for one of these reasons: 1) Remote access on the server is not enabled 2) The remote computer is turned off 3) The remote computer is not available on the network

then goes back to connecting once and immediately disconnecting.

All of the updates are installed. The firewall has been correctly configured to let RDP traffic through. The remote setting is "Allow connections from computers running any version of Remote Desktop". I tried creating a second user, and when I can't connect, I can't connect to that user either. I've tried both soft and hard reboots, neither of which help. I've tried connecting from two different computers (both running Windows 7) from two different networks (work and home), and the behavior is the same.

Everything else on the server continues to run fine (IIS-served http pages, Tomcat-served java pages, svn, ping).

The "fix" that the tech guys supply is simply logging into the console on their end, after which point I can connnect 2 or 3 times again.

The event viewer on the server has "authentication failure" (or something similar) events generated when I attempt to log in and can't. I can't get to the actual event at the moment as I'm currently in the can't connect stage, and waiting for the techs to log in. But when I searched for the event earlier this morning I couldn't find anything useful.

Can anyone help?

9 Answers 9


I had a similar thing as well with regards to Windows Updates. One of the updates seemed to disable RDP and VNC Services but local login was fine.

I ended up having LogMeIn installed by a local tech and when I logged in with my account I found a dialog waiting for me to click on that said 'Windows Service Pack 1 installed Successfully' or something to that effect. After clicking OK everything worked fine.

Thanks Microsoft.

  • This seems to be the most likely problem. The first thing I did after the server was provisioned was install updates; however when the server was first created I also wasn't able to rdp until someone logged in on their end. I didn't pay much attention to it at the time though. I ended up getting the server reprovisioned, and the tech made some changes to the GPO. Now it is working. Time to install 100+ updates one by one to see if I can find the one that breaks it :D
    – carpat
    Commented Apr 10, 2012 at 19:54
  • 3
    This has happened to me 3 times now and I can confirm it's SP1. The problem arises if you install SP1 as user X. No other account (e.g. local tech support) will get the dialog with the OK button other than user X and RDP will not be available until OK is clicked. Not sure what happens if it's installed via Windows Automatic Update. Commented Apr 21, 2012 at 13:52
  • Welcome The Diamond Z - Yours, Microsoft
    – Marin
    Commented Oct 10, 2019 at 10:26

I had a similar problem with an Azure VM.

Turns out that it was doing Windows Updates. From the Azure management portal, the Boot Diagnostics panel shows a picture of the current screen, and it was showing this: enter image description here


The issue is still happening on WS2012R2 machines. After installing all of the updates on the fresh and clean instance of WS2012R2, I did get login and password prompt while trying to RDP, but it immediately disappeared after hitting Enter.

Try to change server authentication settings in RDP client:

  1. Advanced Tab.
  2. Choose Connect and don't warn me OR Warn me if you had the previous option before.

enter image description here

  • I had this also on WS2012R2... turns out it was in the middle of a reboot and installing updates. Fellow Googler - this might also be what your server is doing, give it an hour or so and try again :)
    – James Love
    Commented Apr 22, 2020 at 13:06

Not knowing how the back end of your RDS enviroment is, my solution is just a guess. I've seen similar isues when you have a RD farm configured with DNS round robin (simple load balancing). Someone either changes the IP address of a farm member server or the server drops out after the client computer has cached the IP address. When the client goes to connect to the RDgateway.somedomain.com which it has cached as, authentication fails and you get the error. Try going to command prompt and running ipconfig /flushdns on the client to clear any old records.

  • Unfortunately that didn't help.
    – carpat
    Commented Apr 10, 2012 at 19:53

I don't usually like "me too" answers, but the same happened to me in a fairly consistent way, so I'd like to remark it.

Looks like installing SP1 (via Windows Update or via the standalone installer) effectively disables Remote Desktop until someone actually clicks "OK" on that "SP1 installed succesfully" window.


We are using AADServer for multiple RDP connection to Windows 7. It looks like KB2984972 isn't compatible. So uninstalling KB2984972 helps me. Thx Gabriel


I had the same exact problem happen to me today after installing SP1 on Windows 2008 R2 Enterprise. In my case, I did have available Windows updates which I downloaded and installed and that fixed the issue for me.


If you are not able to RDP after installing the SP1 update, applying the next 7 available updates should fix the problem. It did for me. :)


Uninstall KB2984972, or re-install it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .