I have server running Zentyal. And I have a problem with joining my domain. The problem exists with only my laptop. I've tried some other PC's and they successfully join the domain.

All the machines that I used run windows 7.

I tried to ping the domain controller from my laptop and it was successful. I also tried the other way around and that was also successful.

When I search Google I found some "fixes" that should work but they did not work for me.

  1. I changed my dns server aadress to my domain controller.
  2. I set my default gateway to domain controller ip but sill nothing.

Here's the error message that I get when I try to join the domain:

The domain name "KK" might be a NetBIOS domain name. If this is the case, verify that the domain name is properly registered with WINS.

If you are certain that the name is not a NetBIOS domain name, then the following information can help you troubleshoot your DNS configuration.

The following error occurred when DNS was queried for the service location (SRV) resource record used to locate an Active Directory Domain Controller (AD DC) for domain "KK":

The error was: "DNS name does not exist." (error code 0x0000232B RCODE_NAME_ERROR)

  • 1
    Just to be clear - do the zentyal server and the problem PC both point to the same DNS server? – uSlackr Apr 6 '12 at 19:29
  • 1
    Have you tried using the domain's fully-qualified name? Is the laptop using the domain controller for DNS resolution? – Shane Madden Apr 6 '12 at 19:58
  • Fix #2 (set default GW to the domain controller IP) doesn't look right. I'd undo this one if I were you - unless your domain controller is also a router. – Adam Thompson Jun 25 '14 at 8:14

As Zentyal uses OpenLDAP for it's Domain system, Windows registry needs to be changed so it can communicate with it. There is already a guide on Zentyal's website to fix this issue:


If your OS is up to date then you wont need to install the Hotfix and just go ahead with downloading the reg file and run it. After restart your computer and you are good to go.

If this doesn't fix your problem, make sure your Firewall is set so that they can communicate with the server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.