7

Context:

We have an AD/GPO-managed corporate network with a little over a hundred PCs running Windows 7 x64, and a few managed printers. Our Server2008R2 primary domain controller is configured as a print server for them all.

Problem:

After a recent windows update and restart (no printer driver updates were included) on the DC, a particular shared printer (Lexmark T650) has begin exhibiting some strange behavior. First, it prints a preceding and following blank page for almost every document, on jobs submitted by about half of client machines (no separator page is configured on the server or any of the clients I've seen). Second, whenever someone tries to access "Printing Preferences" on any client, they recieve the following error message (this happens everywhere, 100% of the time, and didn't happen before the update on the DC):

enter image description here

Once they click "OK", the prefs screen appears (with no separator page selected) and everything seems fine. I'm not even sure if these two issues are related, but everyone seems affected by one or both of those issues.

What I've Tried:

I've been hesitant to un-deploy the problem printer, or remove it via GPO, as it's pretty heavily used. I've tried updating (via MS update and our internal WSUS server) client machines and the DC. No printer driver updates have appeared, and no number of updates or restarts on the server or the client seems to have achieved anything other than my boss getting grumpy that I'm bouncing the domain controller so often. I've tried deleting the drivers on the server, and re-installing them from the original source that has worked for the past year...no change. I've tried selecting "New Driver" for one of the shared printers on a client machine, running as domain admin, and pushed the latest driver found by MSupdate back up to the DC. This changed the version number of the driver recorded in the print server manager, but caused no change--on the client I pushed from, or on any other. The error still appears.

Question:

Why the heck is this happening? Obviously, I got a bad driver from somewhere, but how do I get rid of it? I don't know of any "roll back drivers" functionality for centrally managed print drivers like Windows offers for other devices. How would I a) get this issue resolved on a client, and b) push the fix to the other members of the domain?

1
  • Just a nitpick, but there is no such thing as a Primary Domain Controller anymore. That went away when NT4 died (thankfully). – MDMarra May 16 '12 at 23:04
6

Have you tried the latest driver update from the vendor's website? Relying on Microsoft for 3rd party drivers is a bad idea.

The trick to getting clients to download a new driver quickly is to edit the share path of the printer on the server. Change it (or even unshare it) for a minute or so, which will cause the printers to go offline. Then change it back to the original config. The clients will see that the printer is available again and will pull down a new driver if there is one available on the server.

They should do this anyway when they establish a new connection to the printer (after reboot, etc), but this makes it happen immediately.

0

I had the issue with my GPO printers were showing "Update Driver" on the printer when a user was logged in. They didn't have access to update the driver, and when I authenticated as an admin, it would look like it was downloading the driver, but then nothing changed. I would still see "Update Driver" in the right click dialog options for that printer.

After some research, I found this related issue.

  • I downloaded the latest driver from our printer vendor to our print server. The key is to make sure that your printer vendor offers a "Package Aware Print Driver," which basically means that it is signed.
  • Go to your printer server, open Print Management, choose printer, right click printer properties, advanced tab, and click new driver and point it to the .inf file of the latest printer driver that you just downloaded, then click OK. After a few moments, you should see the new printer driver version number next to the printer in Print Management printer view.
  • Make sure that you have the GPO properly setup and that you have added the Point and Print setting.
    • Computer Configuration \ Policies \ Administrative Templates \ Printers \ Point and Print Restrictions -> Enabled
    • Check users can only point and print to these servers.
    • Enter your server names
    • When installing drivers for a new connection: Do not show warning or elevation prompt
    • When updating drivers for an existing connection: Do not show warning or elevation prompt
  • Save the GPO
  • Run gpupdate /force on the end user PC and reboot twice, just to be sure.
  • If you find that there is a printer that still cannot be updated when the user is logged in, open the print queue, select printer \ pause printing.
  • While still in the printer queue, select printer \ pause printing again to un-pause it. The driver will automatically be updated and you shouldn't see the "Update Driver" menu option again when right clicking on the printer and the end user will be able to print to the printer again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.