Our old Small Business Server 2003 (acting as our domain controller) was on the fritz, so we replaced it with a new Windows Server 2008 box and set the server up as our new domain controller. In hindsight, it may have been a mistake, but we set up the new server as a replacement and tried to keep as much the same as possible, including the DOMAIN name. The problem was, that even though the domain name was the same, the guest computers somehow still realized it was not the exact same domain. We had to unjoin and rejoin the domain and port over everyone's documents and settings.

This morning, when I attempted to connect to my local SQL Server Instance, it was saying that my login failed. When I tried to use the SQL Management Studio, it throws the error "Package 'Microsoft SQL Management Studio Package' failed to load" on startup, then exits without giving me a chance to change the login. I am using Mixed Authentication and have an administrative account as a backup.

Ideas? If there is a more appropriate stack, please let me know where to put it.

  • The reason for the problems is that all the machines (including SQL) map domains and logins by SID, not by domain name. So when you built the new domain the SIDs didn't match so nothing was able to connect to the new domain.
    – mrdenny
    Apr 9, 2012 at 17:47

2 Answers 2


Try logging in as the SQL sa user and changing the server logins so your Windows user has permission to log in.

Windows doesn't just use the domain name, there's all sorts of GUID's it uses internally, which is also why your client computers knew this wasn't the same domain as before. Your SQL installation is probably referencing your user GUID from the old domain and not this new one.

You might also want to check the account you're trying to log in with isn't locked out, both in Active Directory and SQL.

  • Only way I've administered is via SQL Management Studio. Do I have to do this via the command prompt some way? The error occurs immediately after starting SQL Management Studio, so there is no where to change my username. I tried launching from the command prompt but the same thing happens.
    – Sam
    Apr 9, 2012 at 16:04
  • When you load SSMS, the login window should appear - do you get this or does it error before even showing you that? Apr 9, 2012 at 16:05
  • Errs before that.
    – Sam
    Apr 9, 2012 at 16:06
  • Have you got SSMS set up to auto log in with some switches on the shortcut? Apr 9, 2012 at 16:08
  • Nope, checked that already. Tried to go into the Control Panel and attempt a repair, but I can't find it in there either. Perhaps I should download the stand-alone and try to re-install?
    – Sam
    Apr 9, 2012 at 16:10

So, what I ended up doing was blowing away the SQL Server App Data in my User directory. When I rebooted, it set up a new profile and launched SQL Express.

At that point I was able to log in with my 'sa' account, delete the existing domain account, then re-add it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .