The quick and dirty: the machine is a Dell Poweredge 1950, dual xeon quad cores, 8GB of ram, 2 2TB seagate SATAs in (supposed to be raid1) using a Perc 5i raid card. They are hot-swappable with a back-plane. I can build the raid fine and after a little while an install of server 08 r2 will blue screen and restart. When it comes up the raid controller says "Foreign Configuration Found." When I go into the raid configuration panel there is no raid listed but I can import the "foreign config", and the OS will boot up fine, until it blue screens again after a little while.

The issue is OS independent. I have tried swapping raid cards, swapping the RAM module on the raid card and swapping the raid battery, all to no avail. Its almost as if there is a loose connection from the raid card to the back plane and both of disks get lost and the raid card drops the config. But it sees the disks fine when it boots back up.

The raid card uses a SCSI SAS cable to connect to the back-plane so I guess the next step is to replace that, but... then I might as well replace the back-plane with a SCSI SAS to sata breakout cable, but... then I need a way to power the disks.

Sorry for the wall of txt but it would be great to get some thoughts from people who worked with perc raid cards or poweredge servers with this type of issue before. Ironically I want to get this system up and running so I can work on MCITP labs. Thank you for any/all help and feel free to ask questions!

4 Answers 4


Another thing to consider is what type of drives you have connected to the controller. If you've connected consumer grade drives you should be aware that the PERC is expecting a FAST response (as in NOW not 2 or 3 seconds) on a write.


Make sure the bios is completely up to date, along with the firmware on the Perc 5/i. Also, check the firmware level on the drives as well.

Here is the link for the bios update: ftp://ftp.us.dell.com/bios/PE1950_BIOS_WIN_2.7.0.EXE Here is the link for the firmware update: ftp://ftp.us.dell.com/SAS-RAID/RAID_FRMW_WIN_R189337.EXE For the drive firmware, go to support.dell.com and select your drive and then download the appropriate firmware.

  • Agreed, those are good first steps. Odd that it gives you that error. If the raid card is dying in some way (card failure, battery, etc), the config should still be on the disk. I would expect that you would get a message about a config mismatch instead.
    – Tatas
    Apr 9, 2012 at 16:01

Your process of elimination seems fine. It's worth upgrading the BIOS's as mentioned - there will be one for the backplace as well. http://www.dell.com/support/drivers/uk/en/ukbsdt1/DriverDetails?DriverId=9WH0P&FileId=2731096423&DriverName=Dell%20SAS%20Backplane%20Firmware%2C%20v.1.05%2C%20A01&productCode=poweredge-1950&urlProductCode=False

If you have Dell certified drives it's worth upgrading the firmware on those as well - find as appropriate on Dell website.

If you wish to try breakout cables instead to test the backplane - as you mentioned powering them will be an issue unless you are happy to make a cable yourself - there is a 20 or so pin power connector to the backplane that supplies enough power.


Hi I had similar issues and solved them with these settings in PERC

  1. Make sure that the BIOS and firmware is updated with the latest
  2. CTRL + R to enter the Perc during boot
  3. Press CTRL + N twice go to the CTRL Mgmt page and only select Enable controller BIOS. Disable "Enable BIOS Stop on Error".
  4. Then CTRL + N Virtual Disk Management - Advanced Settings Stripe 64kb, Read Policy - No Read Ahead, Write Policy - Write Through

These settings got me working hope that they will help you too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.