I have been trying to sort out some time sync issues involving two domain controllers and seem to have ended up with a bigger problem. It's horrible.

They are both virtual machines (one being on Amazon EC2), which I think may complicate things regarding time servers.

The primary DC with all the FSMO roles is on the LAN. I reset its time server configuration like this (from memory):

net stop w32time
w23tm /unregister
shutdown /r /t 0
w32tm /register
w32tm /config /manualpeerlist:”0.uk.pool.ntp.org,1.uk.pool.ntp.org,2.uk.pool.ntp.org,3.uk.pool.ntp.org” /syncfromflags:manual /reliable:yes /update
W32tm /config /update
net start w32time
reg QUERY HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Config /v AnnounceFlags

I checked to see if it was set to 0x05, which it was. The output for...

w32tm /query /status

Leap Indicator: 0(no warning) Stratum: 1 (primary reference - syncd by radio clock) Precision: -6 (15.625ms per tick) Root Delay: 0.0000000s Root Dispersion: 10.0000000s ReferenceId: 0x4C4F434C (source name: "LOCL") Last Successful Sync Time: 10/04/2012 15:03:27 Source: Local CMOS Clock Poll Interval: 6 (64s)

While this was not what was intended, I thought I would sort it out after I made sure that the remote DC was syncing with it first. On the Amazon EC2 remote replica DC (Windows Server 2008 R2 Core)...

net stop w32time
w32tm /unregister
shutdown /r /t 0
w32time /register
net start w32time

This is where it all goes wrong

System error 1290 has occurred.

The service start failed since one or more services in the same process have an incompatible service SID type setting. A service with restricted service SID type can only coexist in the same process with other services with a restricted SID type. If the service SID type for this service was just configured, the hosting process must be restarted in order to start this service.

I cannot get the w32time service to start. I've tried resetting the time settings and tried to reverse what I have done.

The Ec2Config service cannot start either, as it depends on the w32time service.

All the solutions I have seen involve going into the telephony service registry settings, but as it is Server Core, it does not have that role, and I cannot see the relationship between that and the time service. w32time runs in the LocalService group and this telephony service which does not exist on Core runs in the NetworkService group.

Could this have something to do with the process (svchost.exe) not being able to be run as a domain account, as it now a domain controller, but originally it ran as a local user group, or something like that?

There seem to be a lot of cases of people having this problem, but the only solution has to do with the (non-existant on Core) telephony service. Who even uses that?


Hi i had exactly the same issue.

I used the fixit service from: http://support.microsoft.com/kb/816042

Copied it across to the server core PDC install, right click the msi and unclicked block (otherwise you will get accessed denied errors when trying to run it).

Ran the msi from within the core console, and rebooted.

I then set my clock as accurately as possible (to allow sync with allowed time difference between local server time and remote time server), and entered my settings again:

w32tm /config /manualpeerlist:0.europe.pool.ntp.org,0x1 /syncfromflags:manual /reliable:yes /update
Net stop w32time & net start w32time
w32tm /resync
w32tm /query /status
w32tm /monitor

Problem is for me no matter what i do on reboot the settings revert back to a month ago!!


  • I had to rebuild the replica DC in the end. Next time I will remember to make a snapshot before making the smallest of configuration changes.
    – paradroid
    Apr 19 '12 at 3:18

On non Workgroup Servers you net to change start triggers

check start trigger for w32time:

sc qtriggerinfo w32time

enable it on network available:

sc triggerinfo w32time start/networkon stop/networkoff

more info: https://support.microsoft.com/en-us/help/2385818/windows-time-service-doesn-t-start-automatically-on-a-workgroup-comput


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.