Update I've tested both machines plugged directly into the modem, DL is 30Mbps, UL is 12Mbps for both machines. IPCop appears to have some issue with the G5.

I have 2 work machines in my office, a PowerMac G5 and a MacBook Air.

Both behind an IPCop firewall. The PowerMac is connected through a gigabit switch, the MacBook Air is connected through a Netgear 802.11g access point that is then plugged into the gigabit switch.

There is also a FreeNAS box, both machines are able to read and write files to it at close to their pipe speeds.

The main problem is when I am trying to upload files to the internet at large. The G5 is only hitting 0.1 - 0.25 Mbps. The Macbook is able to hit 2-3 Mbps.

The setup (G5 / IPCop / Network) has been the same for 5 years. The issues with the internet speed started about 3 months ago. I hadn't tested on the Macbook at this point. I had complained to the ISP, they said their modem needed a firmware update, did that nothing changed. Reset IPCop, turned off squid, etc. No changes. The ISP switched the office over to a better plan with a theoretical 6 Mbps up, still no change.

At this point I tried testing the Macbook, and lo and behold there's the speed. But why? I have tried changing out everything, cables, switches, using another ethernet port on the G5, wiping the system, using DHCP, using manual IPs, changing DNS servers, etc. Nothing works.

I figured that if there was something horribly wrong with the network, then internally I would find a similar issue, but that is perfect. iperf, ping, etc show no dropped packets and near saturation of the internal network.

I'm at a loss as to what the heck is going on. Any ideas would be appreciated!

Below are some screenshots of speedtest.net:

G5: http://i.stack.imgur.com/Cb3GW.png

Macbook Air: enter image description here

  • Apparently, only the upstream is affected which is rather suspicious. ipcop has addons for QoS - any chance you've set up some kind of bandwidth throttle? – the-wabbit Apr 12 '12 at 20:48
  • Have you run these tests with each computer connected to the same point and using the same cable? If not give that a try and post the results (text will do, as there's no need for images). – John Gardeniers Apr 12 '12 at 21:58
  • All IPCop addons were turned off, QoS had no rules that I could find for specific MAC addresses (I've switched IPs, ports, cables, etc to rule those out). The issue will follow the G5 across switch ports as well. The MacBook does not have an ethernet port, but I could try to find a USB adapter, not sure if that will make any difference. – Andrew Jones Apr 12 '12 at 22:49
  • Have you tried the same tests with both devices before the IPcop firewall? Then you would know if IPcop is the problem or not. – Raffael Luthiger Apr 12 '12 at 23:06
  • Both machines do 30down / 12up when plugged directly into the modem bypassing the IPCop firewall. This now poses more questions. Should I just rebuild the firewall? – Andrew Jones Apr 17 '12 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.