I recently upgraded from the previous LTS Ubuntu to Precise and now mysql refuses to start. It complains of the following when I attempt to start it:

╰$ sudo service mysql restart
stop: Unknown instance:
start: Job failed to start

And this shows in "/var/log/mysql/error.log":

120415 23:01:09 [Note] Plugin 'InnoDB' is disabled.
120415 23:01:09 [Note] Plugin 'FEDERATED' is disabled.
120415 23:01:09 [ERROR] Unknown/unsupported storage engine: InnoDB
120415 23:01:09 [ERROR] Aborting

120415 23:01:09 [Note] /usr/sbin/mysqld: Shutdown complete

I've checked permissions on all the mysql directories to make sure it had ownership and I also renamed the previou ib_logs so that it could remake them. I'm just getting no where with this issue right now, after looking at google results for 2 hours.

  • Incidentally, I did get mysql to run by commenting out the "skip_innodb" entry in my.cnf. But I'm fairly certain that I wasn't supposed to solve this that way.
    – Garrett
    Commented Apr 16, 2012 at 1:17
  • Please show all variables from my.cnf that are innodb settings Commented Apr 24, 2012 at 21:26
  • The actual cause is listed in the few log entries before the ones you displayed.
    – danblack
    Commented Nov 14, 2022 at 23:38

9 Answers 9


After checking the logs I found the following error:

[ERROR] Unknown/unsupported storage engine: InnoDB

I removed these files:

rm /var/lib/mysql/ib_logfile0
rm /var/lib/mysql/ib_logfile1 

at /var/lib/mysql

This resolved my problem after restart.

  • 8
    the rm command is used to Remove files rather than rename them as far as i know...
    – Itai Ganot
    Commented May 21, 2014 at 7:06
  • 8
    Those files contain the actual data for your database. You don't want to delete them. Commented Jun 2, 2014 at 20:26
  • 4
    No, the ibdata file contains the data (unless you have file-per-table). The ib_logfile files are the replay logs that contain the data for database-altering transactions that may have been in process when/if the database crashed. If you were able to shutdown the server successfully, deleting these log files won't hurt you. If it crashed, then you need them. But this is a valid answer. If your my.cnf file changes the innodb_log_file_size option and it no longer matches those two files, you will get the error message that the OP states. Deleting/moving so new ones can be made fixes it.
    – Safado
    Commented Jun 30, 2014 at 15:28
  • 2
    Why edits can only be made for 5 minutes is beyond me... I should have stated it is a potential fix for the above mentioned error. As stated by the OP, it was not the fix he needed.
    – Safado
    Commented Jun 30, 2014 at 15:40
  • 2
    This solution also worked for me. No data damaged.
    – TCB13
    Commented Oct 31, 2015 at 16:40

If you really need skip-innodb (use case: low memory footprint), then of course you don't have to comment it out. However, if InnoDB is the default storage engine, the server will fail to start until you tell it which storage engine to use instead, e.g. default-storage-engine=myisam for MyISAM.

So, try this:

$ sudo -u mysql mysqld --skip-innodb --default-storage-engine=myisam
  • 6
    Try to add "default-storage-engine=myisam" to /etc/mysql/my.cnf in the [mysqld] section if you want to have "skip_innodb".
    – pincoded
    Commented Jul 30, 2012 at 20:10
  • Works beautifully. Cheers!
    – Boann
    Commented Nov 12, 2012 at 8:11
  • 4
    What if you want innodb-support?
    – Nilzor
    Commented Jun 5, 2013 at 9:35
  • 1
    Mariadb on Centos 7 added default-storage-engine=myisam on file /etc/my.cnf under [mysqld]. That did the trick. Thx Commented May 3, 2017 at 5:58
  • Then all the db using innodb couldn't be loaded Unknown storage engine 'InnoDB'
    – TomSawyer
    Commented Feb 3, 2023 at 16:26

If you're using MySQL 5.6+ and want to disable InnoDB, don't forget "--default-tmp-storage" or it won't work:

To disable InnoDB, use --innodb=OFF or --skip-innodb. In this case, because the default storage engine is InnoDB, the server will not start unless you also use --default-storage-engine and --default-tmp-storage-engine to set the default to some other engine for both permanent and TEMPORARY tables.


You can add this to your my.cnf:


just to make sure it'll work.

  • +1, Never notice the official document. it should set default-storage-engine and default-tmp-storage-engine, thanks.
    – Giberno
    Commented Nov 7, 2014 at 8:48

Check your mysql error log.

tail -100 /var/log/mysql/error.log

If your log says (like mine did):

InnoDB: Initializing buffer pool, size = 128.0M
InnoDB: mmap(137363456 bytes) failed; errno 12
[ERROR] InnoDB: Cannot allocate memory for the buffer pool

You don't have enough memory to use the default buffer size of 128M

Edit the config file /etc/mysql/my.cnf adding a line to specify a smaller innodb_buffer_pool_size.

# make the buffer pool smaller than 128M since we only have 1 GB of total RAM
innodb_buffer_pool_size = 16M

Save the config file, and start mysql

sudo service mysql start
  • Is spot on here. But could also be hanging processes of the webserver or something eating up the RAM, do check that, too.
    – sjas
    Commented May 8, 2017 at 14:17

I got this error on a modern MariaDB 10.5 system, because I forgot to units on the innodb control lines;

innodb_buffer_pool_size = 4096
innodb_log_file_size    = 1024

instead of

innodb_buffer_pool_size = 4096MB
innodb_log_file_size    = 1024MB

So, if you get this one, check there


I had this problem, when reloading the /var/lib/mysql/ folder into a fresh install of Debian 12.

I had to remove the logfile with

mv /var/lib/mysql/ib_logfile0 /var/lib/mysql/ib_logfile0-bak

and create a new empty file with

echo ""> /var/lib/mysql/ib_logfile0

Now the service starts, but you see a lot of errors like

Aug 30 15:15:31 test mariadbd[40673]: 2023-08-30 15:15:31 0 [ERROR] InnoDB: Page [page id: space=9154, page number=3] log sequence number 258766592934 is in the future! Current system log sequence number 254569578017.
Aug 30 15:15:31 test mariadbd[40673]: 2023-08-30 15:15:31 0 [ERROR] InnoDB: Your database may be corrupt or you may have copied the InnoDB tablespace but not the InnoDB log files. Please refer to https://mariadb.com/kb/en/library/innodb-recovery-modes/ for information about forcing recovery.

I use 10.11.3-MariaDB, so I guess, I have to set in /etc/mysql/mariadb.conf.d/50-server.cnf


(or a higher value if 4 won't suffice)

Then restart with

systemctl restart mysql 

I got this error when I deleted the location I use for tmpdir. If you've recently changed your tmpdir, you might want to check that it's a valid, writable location.


Check that you have enough free space on the disk.

Run this command to view available free space

df -h

I had this same error message but, once I provisioned more space mysql service was able to start normally


Try 2 more things. 1. Lower the innodb buffer pool size. 2. Edit mysql initial script and add --innodb option.

I wonder also if your package is buggy. Could you try a different minor version?

Also, I assume your mysql server got upgraded as well? Maybe that version is broken? Precise is not final yet.

  • Already did that, to no effect.
    – Garrett
    Commented Apr 16, 2012 at 3:53
  • Sorry, edited it with some things to try, more like a bad package. Try to use the mysql.com version or percona which are usually more stable.
    – johnshen64
    Commented Apr 16, 2012 at 4:25
  • Also make sure the old package is completely purged, when the new is installed.
    – johnshen64
    Commented Apr 16, 2012 at 5:07
  • Would purging the package completely result in lost database information?
    – Garrett
    Commented Apr 16, 2012 at 6:25
  • Should not, but to be safe you should always backup your DBS.
    – johnshen64
    Commented Apr 16, 2012 at 14:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .