3

I have a normal hardware, I just installed Ubuntu 11.04 anew. But something's completely wrong. PHPunit tests are REALLY slow.

I have no idea what's wrong. With ext3 all was normal.

Thanks.

  • 1
    You re-installed the entire operating system and you think the filesystem choice is the problem? Why do you think this? Could anything else be different? – Ladadadada Apr 16 '12 at 15:00
  • 1
    Have you looked at dmesg or done some disk/smart tests to see if the disk is OK? – Tim Apr 16 '12 at 15:07
  • 1
    By normal do you mean non-virtualized? – HTTP500 Apr 16 '12 at 15:13
  • 1
    What is the load and memory usage of the system? How big is your database? Have you tried running the queries directly against MYSQL? What about using an EXPLAIN on one of the aforementioned queries? Assuming its the file system is jumping the gun in a big way. – Andrew M. Apr 16 '12 at 17:02
  • 1
    How would the hard drive seller know if the disk is OK now? – ceejayoz Apr 16 '12 at 18:27
7

It looks like setting barrier=0 as a mount option will help with performance.

See MySQL bug #46959.

Test in a Staging environment first!

Hope this helps.

  • just for a record - i've noticed that the bug #46959 is two or three years old, but still reproduces on the new Ubuntu. – valk Apr 16 '12 at 21:02
  • also, found this. "barriers are disabled by default because they have a serious impact on performance" - in my case they were ENABLED, and serious impact in my case was DISASTROUS :) – valk Apr 16 '12 at 21:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.