I wonder if anybody tried running ASPX pages in 32-bit Windows Server 2003 Enterprise Edition? I have dozens of production web servers that use 2003 Standard and they never have this problem. Here is what I got:

  1. Fresh instance of 2003 EE, IIS and ASP.NET installed on two test servers with very different hardware, everything fully patched.

  2. Simple "hello world" html page "" works fine in all browsers.

  3. When I rename this page to "", Firefox instantly gives the "Connection interrupted" error. There is no additional information in Event Logs or IIS logs. The other browsers also cannot display the page (IE says "cannot display the webpage")

I've tested this on the default web site as well as a brand new website, also tried switching between ASP.NET 1.1 and ASP.NET 2.0 - still getting the same error. My login is a local admin, and I've tried giving Admin permissions to "NETWORK SERVICE", "ASPNET" and "IUSER_*" accounts with no luck. Also, all basic tricks like rebooting, disabling the firewall, reinstalling .NET and IIS did not work.

There are two other clues that I observed on both of these servers right after installing the Enterprise Edition OS: 1. Initially, IIS was giving a security exception when I tried to load even static Html pages or images. I had to use Component Services to allow DCOM activation to the IIS Admin Service, then static files started working. 2. When I try to manipulate some Web Service Extentions (i.e. prohibit CGI Extensions), MMC crashes with "MMC has detected an error in a snap-in. It is recommended that you shut down and restart MMC".

I'll appreciate any hints on working around this issue!

PS. The reason why I am trying to deploy the Enterprise Edition is that it supports more than 4GB of RAM, and some of my apps are not yet ready to run on a 64-bit OS...

5 Answers 5


There are various things to check when asp.net starts acting all funky. Checking to make sure the extensions are allowed is one, though you usually end up getting 404 not found errors rather than other sorts of failures (this is an intentionally bogus error designed to avoid leaking information to potential hackers).

However, most sorts of troubleshooting eventualy come down to reinstalling the .NET Framework and then running aspnet_regiis.exe to reset everything. There shouldn't be any differences between IIS on 2k3EE vs 2k3SE.

Also, remember that IIS isn't PAE-aware so even if you do have tons of RAM on your box, you might still have problems taking advantage of it in any given app pool.


I have experienced a similar situation when I installed IIS after installing the appropriate version of .NET. Basically, when .NET installed, it did not detect IIS and therefore did not install the appropriate libraries to let ASP.NET work.

If you re-install .NET from the Add/Remove programs window, this should fix your problem.

  • I went ahead and uninstalled all versions of .NET Framework, then did a clean install, and still getting the same "Connection Interrupted" error :( I also found a 2 year old post on the same exact issue that has not been resolved yet: issociate.de/board/post/402048/… Jul 9, 2009 at 15:23

In the past I have had problems which mysteriously went away by running "aspnet_regiis.exe -i"

This lives in the Windows\Microsoft.NET\Framework\ [Version]\ directory.


Ok, none of the above answers worked, so I ended up using Microsoft Support for this one. As it appears, the issue is broader than just Enterprise Edition of Windows Server 2003, and it is very well known at Microsoft. It boils down to an incompatible version of asp.dll that somehow gets installed when you are using the regular ISO images. Here are some details: http://support.microsoft.com/?id=907275.

In my case, reinstalling SP2 fixed the problem.

  • Don't forget to tick this as your accepted answer! Jul 22, 2009 at 12:37


Specifically, check Web Service Extensions in IIS.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .