I was trying to install and configure Xabbix on an ubuntu server. Following their instructions on the wiki the first step fails:

sudo apt-get install build-essential

I get the following error message:

Err http://us-east-1.ec2.archive.ubuntu.com/ubuntu/ oneiric-updates/main linux-libc-dev amd64 3.0.0-16.28
404  Not Found [IP: 80]
Err http://security.ubuntu.com/ubuntu/ oneiric-security/main linux-libc-dev amd64 3.0.0-16.28
404  Not Found [IP: 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/l/linux/linux-libc-dev_3.0.0-16.28_amd64.deb  404  Not Found [IP: 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing

I tried the suggesting of --fix-missing. No luck there.

  • I just found the solution. apt-get update – ChickenFur Apr 17 '12 at 20:41

I ran: apt-get update

Then I was able to run the build-essential installation.

| improve this answer | |

I was not able to install build-essential even after apt-get update. Actually apt-get also failed. This was (in my case) because Ubuntu moves the older version packages (after its support cycle ends) to different URLs. Thus, it will not be accessible to the package manager. The proper solution is to upgrade. But most of the time it is a difficult option, thus we can change the url inside /etc/apt/sources.list from ..in.archive.ubuntu.com/.. to ..old-releases.ubuntu.com/..

Thanks, please refer to the below for the complete explanation https://smyl.es/how-to-fix-ubuntudebian-apt-get-404-not-found-package-repository-errors-saucy-raring-quantal-oneiric-natty/

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.