I've got XP and Win 7 workstations that I'm trying to install network printers onto via a WS2k8 print server, but when I try to do so it tells me the server does not have the correct drivers installed. I've loaded x86 and x64 drivers onto the server for all of my network printers, and they are shared, so why wouldn't a client be able to see them? I've checked the permissions for the drivers and nothing looks fishy.

Furthermore, the printers for which drivers cannot be found should already be deployed using group policy. Some deploy successfully, some not so much....

  • is it a 64 bit windows ? Only 64 bit servers can distribute both 32 and 64 bit drivers. – Mathieu Chateau Apr 19 '12 at 21:55
  • Yes it is a 64 bit version of 2K8. – Devon Apr 20 '12 at 0:09

This may be late but it may answer it for someone else. I ran into this issue with a client. Someone else setup the server with a name that was too long so the FQDN of the server was printserver32bit.domain.local. This name is too long for NETBIOS. So if you used \printserver32bit you would get this error. However, if you used the FQDN it would work and it also worked using \printserver32bi leaving off the last t of the name.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.