This is a curious case where all the devices at hand will link with one another, except for two that just won't detect one another. One device is a single board computer (SBC) with a gigabit nic, the other is a fancy managed gigabit switch.

If I patch the computer into any other switch (have two others models on hand in the lab), computer and switch link up fine. If I plug other computers into the finicky switch, they link up fine, too. But this one SBC just won't even get a link light on any port with the finicky switch - it's as though the cable I plugged in just isn't even there. It's not only that the LED in the RJ45 doesn't light up - the 'port show' command in the switch's management console shows no hint of anything being connected. The ports are set to auto-detect.

I checked the cabling, of course. Cat5e, didn't ohm it, but looks like all four pairs are crimped into the RJ45s ok - besides, same cabling gets 1000Base links with other ports just fine.

At this point, I don't even care if the negotiated link is 10Base, I'd just like to see these ports light up as though they detect one another at all. What could cause something like this?

  • 1
    What do the switch logs say? – womble Apr 20 '12 at 2:40
  • @womble - is a log likely to show anything beyond what I can get with interactive commands in the switch's mgmt console? – JustJeff Apr 20 '12 at 2:46
  • 2
    Yes, that's why I asked. – womble Apr 20 '12 at 2:50
  • If all else fails try a full reset of the finicky switch. – John Gardeniers Apr 20 '12 at 3:18
  • @womble - probed around on the admin menu and didn't find any hint of logging. didn't get a chance today to try the root menu. maybe there? anyway, it's "openware 4.4.1" and I located the manual. maybe Monday between "being statused" I'll get a chance to rtfm =P – JustJeff Apr 21 '12 at 0:27
  1. Be sure that you are using a known good switch port.

  2. Try a different known good cable, even if this one works in other contexts.

  3. Ensure that both interfaces are set to Auto. This is always the first, best option to try when interconnecting gigabit devices.

  4. As @womble said, your fancy gigabit switch almost certainly has the capacity to generate useful log data. You may wish to explore this.

  5. If the two devices simply refuse to negotiate a gigabit link correctly when set to auto and you don't need gigabit performance, try hard-setting both interfaces to 100/Full. Given that both devices are known to work in other circumstances, this is highly likely to work.

  • edited in details since your answer - tried all (10) ports. tried cables that work in other places. didn't mention, but auto was in effect. – JustJeff Apr 20 '12 at 2:58
  • OK. How did configuring 100/Full on both ends work out? – Skyhawk Apr 20 '12 at 23:50
  • wanted to try that, but had too many other items on my plate today. did manage to try to squeak in a non-auto, 1000/full both ends, was going to walk it down the list, didn't get there. anyway, fixed 1000/full didn't play. curiously, the switch does allow "1000/Half". – JustJeff Apr 21 '12 at 0:24
  • Let us know how it goes. If a gigabit link doesn't work when both ends are set to auto, it is pretty much guaranteed also not to work if you set both ends to 1000/Full. Trying 100/Full is a much more constructive troubleshooting step, especially if your time is limited. – Skyhawk Apr 24 '12 at 18:52
  • would have tried that next, but once i saw the jumper misconfiguration, knew it was moot. thanks though! – JustJeff Apr 24 '12 at 20:27

Check the speed negotiation settings on both the SBC and the switch. Set both to auto. If that doesn't work, alter the SBC's negotiation settings through all possible options. So gigabit FD, then gigabit HD (Made ya' look!), then 100Mb FD, then 100Mb HD and down the line of possibilities. It's very likely that there is a peculiar mismatch in negotiation settings that the SBC's NIC does not prefer.

  • 2
    There's no such thing as Gigabit half-duplex links. ;D – Chris S Apr 20 '12 at 2:32
  • @ChrisS I was just testing you... – Wesley Apr 20 '12 at 2:46

Should have seen this earlier - the alternate switch devices that were presumed to be gigabit were not, and there were jumpers on the SBC to configure the NIC as two 10/100 interfaces, or a single gigabit interface. So there was the illusion it was linking up 1G, but it was not, and guess which way the jumpers were set. (hint: not gigabit).

  • Got it. Sounds like running some show commands on the other devices that did communicate successfully, and/or taking a careful look at the link light indication (including color), might have cleared up the illusion of a gigabit connection! I also suspect that if you had included manufacturer/model information for the SBC, someone here might have clued into the possibility of a jumper issue. More information helps us help you! Cheers! – Skyhawk Apr 24 '12 at 20:45
  • @MilesErickson - the other devices weren't managed. The moral of the story: don't believe something's gigabit just b/c someone tells you it is. – JustJeff Apr 24 '12 at 23:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.