I'm having a small problem with access to shared folders on a Domain Controller from Linux.

Here is my setup:

  • 1) Windows 2008 R2 SP1 - DC
  • 2) Windows XP SP 3
  • 3) Linux Debian 6 + Samba server + LikeWise Open


  • Shares on Windows XP are accessible from Linux and Win 2008
  • Shares on Linux are accessible from Win XP and Win 2008
  • Shares on Win 2008 are accessible from Win XP, but not from Linux (error can't list shared folders), I can only see the machine in the network explorer.

I made several user accounts, all administrators & root accounts, just to be sure. Shared folders permissions are all on full control. I tried an other Linux distro like Mint 12 LXDE (error can't mount).Same problems with or without software updates.

What might cause this problem? Is it a Linux or Windows issue? Are there any optional config files I need to check, extra packages on Linux which need to be installed?

Any tips would be appreciated. Thx.

This is the errorlog:

An account failed to log on. Subject: Security ID: NULL SID Account Name: - Account Domain: - Logon ID: 0x0 Logon Type: 3 Account For Which Logon Failed: Security ID: NULL SID Account Name: mint Account Domain: machx.com Failure Information: Failure Reason: Unknown user name or bad password. Status: 0xc000006d Sub Status: 0xc000006a Process Information: Caller Process ID: 0x0 Caller Process Name: - Network Information: Workstation Name: MINTOS Source Network Address: Source Port: 36229 Detailed Authentication Information: Logon Process: NtLmSsp Authentication Package: NTLM Transited Services: - Package Name (NTLM only): - Key Length: 0

  • Can you, from your Linux Distro, in the file explorer, say Nautilus, issue smb://<server_name>/ ? Have you checked the log files in windows ?
    – Feiticeir0
    Apr 25, 2012 at 10:10
  • This did not work.
    – biosphera
    Apr 25, 2012 at 23:57

1 Answer 1


You can try apt-get install smbfs just for a change up of drivers and see if it helps... I have ran into this issue in the past, and the culprit was NTLMv2 being the default security setting for shares on Win2008. It is available on XP, but not the default, NTLM is so that is why that share works perfectly. If you think that might be it, just append sec=ntlmv2 under your mount options. Here's an example. mount -t cifs -o username=testIt,sec=ntlmv2 // /mnt/testDir (Oh, and just to let you know, if smbfs isn't installed that will error, complaining about a password. If smbfs is installed, it will prompt you for a password. I guess that package has a modded version of the mount.cifs command in it.)

  • smbfs is deprecated. In fact, it's probably not a real package in debian anymore.
    – wazoox
    Apr 25, 2012 at 14:16
  • I tried your info, but without result. So I started over again for the Linux machine clean install, installed every package step by step, LikeWise to join the domain etc. I have acces now without a problem.
    – biosphera
    Apr 26, 2012 at 0:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .