I run Proxmox 2.0, and installed Windows 2003 R2 (32-bit) server on it. I've use VIRTIO disk and NIC virtual devices (and installed appropriate drivers into Windows), and everything's fine. Physical server is HP DL 180 G6 with RAID 410i (256 Mb battery-backed cache, 4 x 300 Gb 15K SAS disks in RAID10). Server is UPS-backed (of course) so it won't suddenly be poweroff.

Now I see I can set disk mode in Proxmox to 'default (no cache)', 'Direct sync', 'Write through', 'Write back', 'Write back (unsafe)', and I can also on/off cache mode in Windows iеself. I'd like to optimize Windows Server IO speed, so I'd like to use 'write back'-ed disks, while at the same time it looks like I don't need Windows cache on disks at all.

What's the better strategy for my case? What mode I need to set for virtual disks in Proxmox, and what setting are better to use inside Windows Server in VM?

By the way, what if I install Debian in another VM on the same Proxmox - what disks modes should I set in Proxmox for better IO performance of Debian?

1 Answer 1


From IBM's KVM performance optimisation best practice ( http://publib.boulder.ibm.com/infocenter/lnxinfo/v3r0m0/topic/liaat/liaatbpblockioperf.htm ), you should:

  • setup a LVM storage in Proxmox to run VMs straight from logical volumes,
  • keep the default 'no cache' option in Proxmox,
  • enable deadline scheduler on your disks

About the best settings to use in Windows, I'd love to know too as I should install a really similar setup in a couple of weeks...

  • Where exactly did you read that? When I checked that link, I found a completely different caching recommendation: "For local or direct-attached storage, it is recommended that you use writethrough mode... caching mode none is recommended for remote NFS storage." Jul 25, 2012 at 16:14
  • Actually one gives better read performance (writethrough), and the other better write performance (none). As Alexander HW config includes BBWC, this should compensate for decreased. From the (few) tests I've done (with ATTO), reads are not so problematic as writes and so, cache=none is the option to go.
    – silopolis
    Jul 25, 2012 at 16:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .