I'm trying to restore data from LTO-3 tapes written by a Tandberg TS800 LTO-3 drive, but since the original drive is now underwater (literally!) I'm trying to read them on an IBM LTO-3 drive. But they won't read. If I eject and reinsert the tape then about every fourth time the IBM drive will read the tape label and see it as a valid backup tape, but any attempt to restore data produces an error.

The tapes were backing up fine in the Tandberg, and we have done restores from them with the Tandberg drive so I'm confident the Tandberg drive was fine (before it got flooded). I'm not 100% sure about the IBM drive since it's out of our stores and it was last used 18 months ago, but I've no reason to think it's faulty.

Surely there shouldn't be any problem moving a tape between different LTO-3 drives. I recall problems with DDS-3 drives, though even those were pretty rare. I'm trying to source a Tandberg drive to try that, but in the mean time can anyone suggest what might be wrong and how to fix it? Is it most likely that my spare IBM drive is faulty or have other people seen problems moving tapes between differet LTO-3 drives?

Any suggestions gratefully received!

John Rennie

  • 1
    What do you mean exactly by "they don't read"? Does the drive refuses to read the tape, or does the software report an error? What is the on-tape data format? – wazoox Jul 9 '09 at 15:43

The first thing i would suggest is to run a cleaning tape through it at least once - possibly twice it'd bet there is a decent amount of dust on the tape heads. Which would cause symptoms like what you are describing.

Also have you tried a different tape? There might be somethign wrong with the tape.

Are there any logs on the backup machine as far as scsi errors?

  • Cleaned the drive (obviously :-). None of the tapes written on the Tandberg work in the IBM, and some of the tapes are newer than others so I don't think the problem is the tapes. No SCSI errors are being generated when we try and read the tapes in the IBM. Now I've had a chance to stop panicing, it has to be the IBM drive, doesn't it? – John Rennie Jul 9 '09 at 14:44
  • +1 to the cleaning tape idea, but don't over-clean. If you think your IBM drive is faulty keep important tapes out of it until you know for sure. Test reading some other tapes written by the Tandberg drive that are less important, if you have any. I've never had problems moving LTO tapes between drives of different makes / models. I suspect you have a faulty drive. – Evan Anderson Jul 9 '09 at 14:46
  • Yep, the IBM drive would be my suspect at this time. Although we did ONCE have an issue where the scsi card went bad, and didn't throw errors but wrote a lot of bad data. Last gasp would be to try a new SCSI controler. – Zypher Jul 9 '09 at 14:53
  • @John Rennie: It wasn't obvious. Lots of people fail to think of that sort of thing. – T.J. Crowder Jan 29 '10 at 13:33

Phew, problem solved. It looks like it was the IBM drive. We found another Tandberg and the data is now restored. Next job is to get that IBM drive back to head office and check it to see if it's faulty or if there really is a problem reading tapes from other drives.

I like to berate our on site chaps when they don't change the tapes by asking what they think would happen if their office got burnt down or flooded. Well one office now knows! It was the severe showers in London on Monday night/Tuesday morning. They came in on Tuesday morning to find a meter of water in the server room. All I can say is thank God they weren't keeping the tapes in the server room too :-)

Thanks to all who responded. Eric Mayo, I take my hat off to you for making a DDS3 drive work by manually adjusting the the head alignment. Bet you couldn't do it with an LTO-3 drive though :-)

I'll mark this as the answer to close the question (well in 48 hours since ServerFault won't let me accept this answre immediately).


  • Historically this isn't uncommon with tape drives: Drives from Mfr. A may not read tapes written on drives from Mfr. B. -- The LTO standard allegedly helps solve this, but every storage guy I know takes the paranoid approach of having the same model drives everywhere plus a spare or two, "just in case" :-) – voretaq7 Jan 29 '10 at 16:51

I once had a similar situation with a DDS-3 unit and I found that if I opened the device and adjusted the R/W head with a screw driver, I was able to get the tape drive to read data written by another brand of tape drive.

Some tape units have self calibrating heads I think so this may not work; I'm not a tape drive expert here... I would be curious to know if the IBM unit can be re calibrated via software tools and if not, try cracking the unit open - obviously only doing this if you don't use the unit for back-ups or don't plan to use it after you restore the data.

Just an idea...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.