15

I am attempting to start SQL Server Browser through the SQL Server Configuration Manager. However, not only is the "state" of SQL Server Browser stopped, but the options to Start, Stop, Pause, Resume, and Restart are all disabled (both in the right-click context menu, and through the Properties dialog).

(Also, in the Properties dialog, I have attempted all 3 options for "built-in account": Local System, Local Service, and Network Service. I have also attempted "This Account" with various options. In all cases, the functionality remains disabled.)

I initially thought it might be a port issue. Apparently, SQL Server Browser uses Port 1434. However, using a program called CurrPorts, I find that Port 1434 is not being used by any program.

Can anyone help?

21

The service itself is disabled by default. In SQL Server Configuration Manager, go to Properties -> Service tab -> Start Mode = Automatic.

|improve this answer|||||
1

If it is disabled, go to Control Panel->Administrative Tools->Services, and look for the SQL Server Agent. Right-click, and select "Properties." From the "Startup Type" dropdown, change from "Disabled" to "Automatic".

|improve this answer|||||
  • The OP is actually looking for the SQL Server Browser service rather than the Agent, but otherwise your suggestion may (or may not) help. – Katherine Villyard Oct 4 '15 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.