35

I am using Windows 7 Professional. When I am trying to start DefaultAppPool in IIS 7.0, I am getting error -

Service WAS was not found on computer '.'.

Is there any changes in setting need to be done?

enter image description here

49

Well, start off by checking if it is installed.

enter image description here

Control Panel > Programs > Programs and Features > Windows Process Activation Service

| improve this answer | |
  • 11
    and then run iisreset /restart to make sure both services will run – itsho Jul 16 '13 at 9:16
  • 1
    In case it helps anyone else, I already had these enabled but was still getting the error. I just disabled IIS features, restarted my pc, enabled them again, then restarted again and it solved my issue. – Jerreck Dec 19 '15 at 4:54
7

Control Panel > Programs > Turn Windows features on or off > Windows Process Activation Service > SELECT ALL > Click OK

| improve this answer | |
  • This was the missing part for me. Thanks @Bopanna! – aditya Oct 15 '19 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.