How can I downgrade vsftpd from the latest Ubuntu package (2.3.5) to version 2.3.2?

I have tried to put this into /etc/apt/preferences file:

Package: vsftpd
Pin: version 2.3.2*
Pin-Priority: 1001

However, every time I do sudo apt-get install vsftpd it installs version 2.3.5: vsftpd_2.3.5-1ubuntu2_i386.deb

Is there something else I need to do or am I doing something wrong?

2 Answers 2


What you are after is not pinning, but holding.

Holding a package can be achieved with

  echo vsftpd hold | dpkg --set-selections

See Ubuntu Pinning Howto

Edit: as for the original question it would probably be easiest to uninstall whatever version is there and download the version you need from Ubuntu Main pool and install it with dpkg -i. Afterwards hold to it as describe above.

  • Hmm I tried holding, but no luck. I think it is because I already had 2.3.5 installed (as it is the latest version in Ubuntu 12.04). I also tried removing vsftpd and then installing it again, but unfortunately it keeps installing 2.3.5. Any other suggestions?
    – j doen
    Apr 30, 2012 at 9:24
  • 1
    It would probably be easiest to download the package from pool and install it with dpkg -i vsftpd_2.3.2-3ubuntu5.1_i386.deb Apr 30, 2012 at 9:32

I was getting "needs read/write" access errors when running the hold command, even with "sudo". It did finally work when I switched to root (sudo su) and ran it as root. Just in case anyone else has the same issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.