Recently I ran into a problem where our D drive was needing moved to another server and coincidentally the WSUS content was in need of a good cleaning. We recently upgraded many things within our network and no longer needed to have all of the older synched files for Windows XP + others. So I figured it would be a good time to reinstall WSUS for a nice clean start.

I first documented the structure of how we have it setup. Then removed the service through control panel. I attempted to reinstall the program and all was fine until the prompt asking to "use the existing IIS default Web Site (recommended)" or "Create a Microsoft Windows Server Update Services Web site". I opted for the default as expected but it would immediately encounter an error, want to close and check for possible resolutions online.

I tried a couple times with similar results. I figured I'd reboot for good measure in case there were some temp files needing cleared out after uninstalling. After booting back up, I tried again with no luck, it had the same problem. So I instead chose the second option (versus the recommended option). This time, the install went fine. It has synchronized with MS, I've created the groups like they were before, but so far no PCs are populating in the folders. This is the same server as before, all names are the same with the exception of it's not the default site now.

I'm assuming there's a problem with the IIS install of the website, or maybe a matter of pointing our GPO to a new site? Currently it's just set at "http://servername". The WSUS site is now named "WSUS Administration" and the pool name is "WsusPool". Would I need to modify the GPO setting to say "http://servername/WsusPool" for it to work?

Thanks for the help!

  • 1
    Please edit this so that's it's readable. Right now it's a great example of a wall of text. – John Gardeniers Apr 30 '12 at 21:42
  • I believe that's a relative statement, I have no trouble reading it at all. I'll break it up though if it's easier for others. – Don May 1 '12 at 19:10

Figured out what the problem was. Because I didn't go with the default website, I had to specify in the GPO the port number. Before it wasn't on there (:80) because it was default, a given. Since the reinstall isn't on the default website, I had to place the port in there like so:

Original - http://servername Afterward - http://servername:5830

Hope this helps someone else, thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.