8

I'm trying to run PHP 5.4.1 ( compiled from source ) but when i try to connect on mysql i get:

Warning: mysql_connect(): The server requested authentication method unknown to the client [mysql_old_password] in

When using PHP 5.3/5.2 it works normally. Any ideas of what cause this problem?

8

Try reading this: link

MySQL introduced longer password hashes in (i think) version 4.1, and your server probably still uses them (check for 16 byte password hashes in your mysql user table). Newer versions use longer password hashes. Your server supports both, but your client (php) seems to support only new ones in this version (and on).

If it's possible, use the solution from the link in the first line, and set your password again with the new hash, but beware, if you're using any other (old) clients which rely on old passwords, compatibility might break. Also try looking for old-password support for MySQL in PHP, but i'm not sure about it.

6
ALTER USER 'mysqlUsername'@'localhost' IDENTIFIED WITH mysql_native_password BY 'mysqlUsernamePassword';
3

I know this is an old topic, but I worked around the issue, without having to upgrade/downgrade anything. Basically I commented out the old_passwords=1 line in my my.cnf file, restarted mysql, added/modified the user which eventually got the 16 byte hash, then I went back and uncommented the old_passwords=1 line, and restarted mysql. So basically:

  • comment old_passwords=1
  • restart mysql
  • add/modify user
  • uncomment old_passwords=1
  • restart mysql

So there you have it: 1 user using new password type, while other users have their old password types. And everybody can log in! ;)

1

Many times this can happen if your MYSQL server is using an old password hash, change the the password Or upgrade the server to get the latest password hash that fixes the authentication problem.

  • 1
    I just changed the db user's password again, assuming MySql would use the new hash. It worked. No other changes were required. – eyal_katz Jul 26 at 3:02
0

I had a similar message when trying to upgrade my mediawiki installation. I am using Netfirms as my hosting provider and I solved this by logging into the control panel, going the MySQL area and changing the database that mediawiki was using. I was then able to proceed with the mediawiki upgrade.

protected by Michael Hampton May 11 at 6:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.